Closed Bug 487125 Opened 11 years ago Closed 10 years ago

Delete attachment loses user-defined tagging of email message on IMAP server or local folders

Categories

(Thunderbird :: General, defect, major)

x86
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 340886

People

(Reporter: beynon, Unassigned)

References

Details

(Whiteboard: closeme 2010-03-25)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.8) Gecko/2009032608 Firefox/3.0.8
Build Identifier: version 2.0.0.21 (20090302)

Deleting an attachment from a message that already has user-defined tags assigned will cause the tag assignment to be dropped.  This happens both on an IMAP server and after copied to Local Folders.  The tags assigned are user-defined in addition to the basic high/medium/low that come pre-installed.


Reproducible: Always

Steps to Reproduce:
1. Tag a message with an attachment (IMAP server Inbox or Local Folders)
2. Delete the attachment (via File menu or right-click on attachment)

Actual Results:  
The tags are gone.  The tag column (if configured to be displayed) shows the tag is no longer assigned.

Expected Results:  
The tag assignment metadata should be preserved even if at attachment is deleted.

Loss of message metadata upon attachment deletion appears to be an ongoing issue ...

Junk status: https://bugzilla.mozilla.org/show_bug.cgi?id=340886
Message status: https://bugzilla.mozilla.org/show_bug.cgi?id=353476
Message position: https://bugzilla.mozilla.org/show_bug.cgi?id=318954

All of these are confusing to a user who expects the message to just have the attachment deleted.
The issue of maintaining database information when deleting attachments is on my radar screen, as I have been doing a campaign to improve the handling of message metadata in various circumstances (for example bug 486007). The issue that you discuss here will almost certainly be resolved at the same time as bug 340886. I don't know what to do with the status of this bug, but I've set a dependency to make the point.
Depends on: 340886
 Michael, can you reproduce bug 353476 in version 3?  (the junk issue should be gone)
Whiteboard: closeme 2010-03-25
Version: unspecified → 2.0
This is fixed in version 3 (3.0.1 MacOSX).
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Thanks Michael
Resolution: FIXED → DUPLICATE
Duplicate of bug: 340886
You need to log in before you can comment on or make changes to this bug.