Closed Bug 487251 Opened 14 years ago Closed 14 years ago

imacros.c.out generation fails: Error: .igroup/.end name mismatch

Categories

(Core :: JavaScript Engine, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla1.9.1b4

People

(Reporter: benjamin, Assigned: brendan)

References

Details

(Keywords: fixed1.9.1)

Attachments

(1 file)

Compiling mozilla-central today, I was trying to land bug 481350, but generation of imacros.c.tmp was failing because the following output was in it:

Error: .igroup/.end name mismatch

This is x86-64, though I hope it doesn't matter.
This regression on mozilla-central appears to coincide with the merge from tracemonkey which included upvar2.
Blocks: upvar2
Flags: blocking1.9.1+
Priority: -- → P1
Blocks: 481350
Argh, patch applied the .end labels to the wrong unlabeled .end lines!
Assignee: general → brendan
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: x86 → All
Target Milestone: --- → mozilla1.9.1b4
Attached patch fixSplinter Review
Seems Mercurial uses too little context by default, at least for imacros.jsasm (context-sensitive, so blame could go to that file -- I'm looking for a fix, not blame justice). Any way to up the default?

/be
Attachment #371505 - Flags: review?(mrbkap)
Comment on attachment 371505 [details] [diff] [review]
fix

[diff]
unified = N

in your .hgrc?
Attachment #371505 - Flags: review?(mrbkap) → review+
Fixed in tm and m-c:

http://hg.mozilla.org/tracemonkey/rev/5a2b060d8c24
http://hg.mozilla.org/mozilla-central/rev/10bf357feece

/be
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
(In reply to comment #4)
> [diff]
> unified = N

You probably don't want this, because it makes your MQ patches have too much context.  This causes conflicts.

I use the settings below and generate patches using `hg qdiff`.

[defaults]
diff=-U 8 -p
qdiff=-U 8
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.