Store account settings outside of prefs.js

RESOLVED DUPLICATE of bug 117406

Status

--
enhancement
RESOLVED DUPLICATE of bug 117406
10 years ago
8 years ago

People

(Reporter: Kensie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
There are several cases where prefs.js either becomes corrupt, or a user needs to reset prefs to fix a problem (sometimes a bad pref is set and the app won't launch).

It seems to make sense to me that we store basic account information outside of prefs.js  I would store:

The info required to access the server - domain, username, port etc.
The info required to access the stored mail on disk - global vs own inbox, location of mail on disk.
(In reply to comment #0)
> There are several cases where prefs.js either becomes corrupt, or a user needs
> to reset prefs to fix a problem (sometimes a bad pref is set and the app won't
> launch).

Storing account prefs in a separate file won't fix the case where a bad pref is set. It would still be set in one or other of the files and just give the user two places to look to try and find it.

> It seems to make sense to me that we store basic account information outside of
> prefs.js

This seems overly complex. For starters we wouldn't be able to use the existing prefs system to do it, meaning we'd have to hand-spin our own (or do a major hack on the existing one so it would separate out files).

This is obviously a problem with Firefox as well, not just Thunderbird. So I'd be tempted to say we should be looking at a core fix to improve handling of prefs.js, e.g. do back ups (bug 364440), try to recover (bug 191101), or something else.

I'm not quite sure what that something else is because the prefs.js writing code already uses a safe output stream, so in theory we shouldn't be corrupting it anyway.
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> (In reply to comment #0)
> > There are several cases where prefs.js either becomes corrupt, or a user needs
> > to reset prefs to fix a problem (sometimes a bad pref is set and the app won't
> > launch).
> 
> Storing account prefs in a separate file won't fix the case where a bad pref is
> set. It would still be set in one or other of the files and just give the user
> two places to look to try and find it.

Let me clarify. The user wouldnt look in the account file for this pref, that pref wouldn't be able to stop TB from loading. The part where it would help is that users could reset their prefs without losing their account info.

> 
> This is obviously a problem with Firefox as well, not just Thunderbird. So I'd
> be tempted to say we should be looking at a core fix to improve handling of
> prefs.js, e.g. do back ups (bug 364440), try to recover (bug 191101), or
> something else.
> 

But firefox stores everything of similar calibur to account settings in other files already. Bookmarks are probably what I'd most compare the account settings to. That or maybe the session.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 117406
You need to log in before you can comment on or make changes to this bug.