Preference 'calendar.alarms.indicator.show' doesn't work anymore.

RESOLVED FIXED in 1.0b1

Status

defect
RESOLVED FIXED
11 years ago
8 years ago

People

(Reporter: bv1578, Assigned: bv1578)

Tracking

unspecified
1.0b1

Details

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.9.1b4pre) Gecko/20090407 Lightning/1.0pre Shredder/3.0b3pre

I think this preference should work in the same way even with changes due to bug 353492 (unless there is still work in progress).



Reproducible: Always

Steps to Reproduce:
----------------------
1. create a new event;
2. set a reminder, save and close dialog;
3. open Config Editor (Tools->Options->Advanced->Config Editor) and write  calendar.alarms.indicator.show in the filter
4. double click on the preference to change status from 'true' to 'false'

Actual Results:  
----------------------
Alarm icon doesn't disappear from the event boxes even when you close the Config Editor and Option window.
You get the same behavior if option 'Show alarm' in calendar properties is unselected (the alarm icon is that one of suppressed alarms).


Expected Results:  
----------------------
Alarm icon should disappear immediately after preference has changed.


----------------------
Regression range:
works with Lightning 1.0pre 090130
fails with Lightning 1.0pre 090131

Perhaps this particular changeset: http://hg.mozilla.org/comm-central/rev/125c3a73ab46 in bug 353492 causes the regression.

Moreover:
- in week-view and day-view, events disappear when you double click on the preference and reappear when you close Config Editor and Option windows though this seems another bug (I haven't found it on bugzilla);

- when the preference is set to false, 'Show alarm' option (in calendar properties dialog) doesn't change alarm icon until Thunderbird restarts, though this issue wouldn't exist if calendar.alarms.indicator.show preference would work.
I've restored the 'if' statement deleted with changeset  http://hg.mozilla.org/comm-central/rev/125c3a73ab46#l5.33 and it seems working, though I don't know whether it was deleted by mistake or by design (with the intention to do something different).
Attachment #371819 - Flags: review?(philipp)
Assignee: nobody → bv1578
Comment on attachment 371819 [details] [diff] [review]
restore a deleted 'if'

>diff --git a/calendar/base/content/calendar-view-core.xml b/calendar/base/content/calendar-view-core.xml
>--- a/calendar/base/content/calendar-view-core.xml
>+++ b/calendar/base/content/calendar-view-core.xml
>@@ -191,19 +191,21 @@
>             var cssClassesArray = categoriesArray.map(formatStringForCSSRule);
>             this.setAttribute("categories", cssClassesArray.join(" "));
>           }
> 
>           // Add alarm icons as needed.
>           let alarms = item.getAlarms({});
>-          let iconsBox = document.getAnonymousElementByAttribute(this, "anonid", "alarm-icons-box");
>-          cal.alarms.addReminderImages(iconsBox, alarms);
>+          if (alarms.length && getPrefSafe("calendar.alarms.indicator.show", true)) {
>+              let iconsBox = document.getAnonymousElementByAttribute(this, "anonid", "alarm-icons-box");
>+              cal.alarms.addReminderImages(iconsBox, alarms);
> 
>-          // Set suppressed status on the icons box
>-          setElementValue(iconsBox,
>-                          item.calendar.getProperty("suppressAlarms") || false,
>-                          "suppressed");
>+              // Set suppressed status on the icons box
>+              setElementValue(iconsBox,
>+                              item.calendar.getProperty("suppressAlarms") || false,
>+                              "suppressed");
>+          }
> 
>           // Set up event box attributes for use in css selectors. Note if
>           // something is added here, it should also be xbl:inherited correctly
>           // in the <content> section of this binding, and all that inherit it.
> 
>           // Event type specific properties
Attachment #371819 - Flags: review?(philipp) → review+
Keywords: checkin-needed
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/48a53ff7e87a>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 1.0
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.