Make thread check happen in DEBUGGER builds

VERIFIED DUPLICATE of bug 489345

Status

Tamarin
Garbage Collection (mmGC)
VERIFIED DUPLICATE of bug 489345
9 years ago
9 years ago

People

(Reporter: Tommy Reilly, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
Provide and API to turn the check off for situations that warrant it, should be on by default for DEBUGGER and !DEBUGGER.  Request from AIR devs who are shooting themselves in the foot with threads.

Updated

9 years ago
Depends on: 487322
(Reporter)

Comment 1

9 years ago
Note that this could be made to work even when the debugger is on if it worked by recording the current thread in MMGC_GCENTER.
(Reporter)

Comment 2

9 years ago
happing for OOM
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 489345

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.