Sometimes, add-ons for older version of Firefox have their Add to Firefox button enabled when overriding experimental add-ons

VERIFIED FIXED in 5.0.4

Status

addons.mozilla.org Graveyard
Public Pages
--
major
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: stephend, Assigned: abuchanan)

Tracking

({regression})

unspecified
5.0.4
x86
All
regression

Details

(URL)

(Reporter)

Description

9 years ago
STR:

1. Load https://preview.addons.mozilla.org/en-US/firefox/browse/type:1/cat:14?show=100&exp=on&sort=name using Firefox 3.0.8
2. Click on the "What's this?" link next to an experimental add-on
3. Click the Back button in Firefox
4. Look at some of the "This add-on is for older versions of Firefox" add-ons

Expected Results:

Add-ons for older versions of Firefox should never have their buttons enabled

Actual Results:

The "Add to Firefox" button is enabled, but doesn't actually let you install the add-on for an older version of Firefox

Screenshot w/Firebug: http://www.grabup.com/uploads/e8add7b4bc045ee4efd26af01ae566a9.png
(Reporter)

Updated

9 years ago
Blocks: 441739
(Reporter)

Updated

9 years ago
Target Milestone: --- → 5.0.4
(Reporter)

Comment 1

9 years ago
Screencast: http://screencast.com/t/mJKR4jHu
(Assignee)

Comment 2

9 years ago
I've fixed two things,

1) I moved the "What's this?" link out of the label, so that clicking the link doesn't check the box

2) I fixed this bug, in that, when you check a box and refresh the page, the incorrect install button is NOT highlighted

BUT, the idea is that when you check a box and refresh the page, the checkbox stays checked.  This is not working on some pages...

/search?q=experimental&cat=all
^ check all the exp. confirm boxes there, refresh the page, and they all stay checked

/browse/type:1/cat:14?show=5&exp=on&sort=name
^ do the same here and none of the boxes stay checked

maybe we can split this bug out and make it a non-blocker?
(Assignee)

Comment 3

9 years ago
r24317 commits the changes in comment #2
bumping this from the 5.0.4 milestone wfm with that patch in.  Stephen - is the original bug fixed?
(Reporter)

Comment 5

9 years ago
(In reply to comment #4)
> bumping this from the 5.0.4 milestone wfm with that patch in.  Stephen - is the
> original bug fixed?

Will know when preview is updating again; I'll test after lunch.
(Assignee)

Comment 6

9 years ago
forget to resolve this
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

9 years ago
(In reply to comment #6)
> forget to resolve this

Verified FIXED using the STR in comment 0; I'll note here a regression: http://www.grabup.com/uploads/9afa66f631553bc7cfc3145e5a89b37c.png -- this would require a rather large CSS fix; I think we can live with it, but we should fix that in 5.0.5.

(I'll spin that bug out.)
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

9 years ago
Spun comment 7 off as bug 487672.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.