mac Display errors in Preferences Dialogs

VERIFIED FIXED in mozilla0.9

Status

SeaMonkey
Themes
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Friedrich HAEUPL, Assigned: andreww)

Tracking

({classic})

Trunk
mozilla0.9
PowerPC
Mac System 8.6
classic

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
In Preference some interfacecomponents appear to be corrupted:
1.  Preferences/Fonts the "Size" popup cannot be selected twice, you have to 
 	select another Popup to be able to change the Size. 
2.  Preferences/Fonts The Size is not displayed
3.  Preferences/Mail&News: The lower box sometimes contains corrupted text
4.  Preferences/Search: The text after the clickbox for Search result is not 		
    always shown

Comment 1

18 years ago
Build: 2000081504 
OS: Mac OS 9.0

I'm only seeing #3, and that's only the first time I go to the Mail and News 
panel. The actual edit field is fine. Surrounding static text seems to be not 
refreshed.


Note: 4 is Classic Skin only. I also see 3. Changing component to Themes.

Gerv
Assignee: matt → hangas
Status: UNCONFIRMED → NEW
Component: Preferences → Themes
Ever confirmed: true
QA Contact: sairuh → paw

Comment 3

18 years ago
Updating QA Contact to pmac@netscape.com
QA Contact: paw → pmac

Comment 4

18 years ago
Sending to Andrew
Assignee: hangas → andreww
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

18 years ago
Seeing wierdness in the languages prefs, the move up , move down buttons look 
strange.

Comment 6

18 years ago
Problems seen in current (12/07) trunk build:

Navigator:
1) Language prefs: the move up/down, add/remove & character coding popup menus
are offscreen on the right side.
2) Smart Browsing: almost half of the Location Bar Autocomplete panel is
offscreen on the bottom.
3) Internet Search: the Search using: popup menu is offscreen on the right side.

Mail and Newsgroups:
1) Message Composition: in Forwarding and Replying to Messages, the Then:
pulldown menu is offscreen on the right side.

These problems almost make the prefs dialog a joke. They were present in the
final release of Netscape 6.00 (not a very good first impression). The default
size of the preferences dialog should be sufficient so that all information can
be obtained and options set without resizing the dialog each time.

These problems are specific to the Modern2 theme. The prefs appear normally when
using the Classic theme.
(Assignee)

Comment 7

18 years ago
Revising summary. This bug is for mac classic skin prefs issues. 
Summary: Display errors in Preferences Dialogs → [classic] mac Display errors in Preferences Dialogs

Comment 8

18 years ago
Themes Triage Team nsbeta1+ (may be a dup of 63616)
(Assignee)

Comment 9

18 years ago
hmm - looks related but probably not a dupe per-se...
setting milestone.
Target Milestone: --- → mozilla0.9

Updated

17 years ago
Keywords: classic

Updated

17 years ago
Summary: [classic] mac Display errors in Preferences Dialogs → mac Display errors in Preferences Dialogs
(Assignee)

Comment 10

17 years ago
I went over all of the points listed in this bug and I'm unable to replicate any 
of them now in mac classic except for some visual wierdness in the Languages 
panel which I will fix now and post a patch here.
(Assignee)

Comment 11

17 years ago
Created attachment 26356 [details] [diff] [review]
patch for communicator.css
(Assignee)

Comment 12

17 years ago
patch is ready. Anyone for review?
Keywords: review

Comment 13

17 years ago
r=jelwell

Comment 14

17 years ago
sr=hewitt
(Assignee)

Comment 15

17 years ago
fix checked into trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 16

17 years ago
Marking verified on Mac (2001-03-05-08-Mtrunk).
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.