browser_bug435788.js fails intermittently

RESOLVED FIXED in mozilla1.9.2a1

Status

defect
RESOLVED FIXED
10 years ago
5 years ago

People

(Reporter: mak, Assigned: mossop)

Tracking

({fixed1.9.1, intermittent-failure})

Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

i've seen this between random failures, i was unable to find a bug filed for it, in case there is one, feel free to dupe

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have seen the right plugin name - Got Test extension 2 , expected Test extension 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have seen the right plugin name - Got Test extension 1 , expected Test extension 2
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have been a failed install - Got Failed, expected Installed
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have been a failed install - Got Installed, expected Failed
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have seen the right plugin name - Got Test extension 2 , expected Test extension 1 
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have seen the right plugin name - Got Test extension 1 , expected Test extension 2 
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have been a failed install - Got Failed, expected Installed
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/toolkit/mozapps/plugins/tests/browser_bug435788.js | Should have been a failed install - Got Installed, expected Failed

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1239209673.1239217443.26718.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1239187781.1239198623.18790.gz
and others before.
Whiteboard: [orange]
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1239384241.1239390698.4966.gz
OS X 10.5.2 mozilla-central unit test
Summary: browser_bug435788 fails intermittently → browser_bug435788.js fails intermittently
(Assignee)

Updated

10 years ago
Duplicate of this bug: 488593
(Assignee)

Updated

10 years ago
Duplicate of this bug: 487717
(Assignee)

Updated

10 years ago
Assignee: nobody → dtownsend
(Assignee)

Updated

10 years ago
Blocks: 435788
No longer depends on: 435788
(Assignee)

Comment 5

10 years ago
Posted patch patch rev 1Splinter Review
Instead of assuming the results will be in the order we expect, search for them in the list.
Attachment #373131 - Flags: review?(robert.bugzilla)
Comment on attachment 373131 [details] [diff] [review]
patch rev 1

>diff --git a/toolkit/mozapps/plugins/tests/browser_bug435788.js b/toolkit/mozapps/plugins/tests/browser_bug435788.js
>--- a/toolkit/mozapps/plugins/tests/browser_bug435788.js
>+++ b/toolkit/mozapps/plugins/tests/browser_bug435788.js
>@@ -15,16 +15,58 @@ function test() {
>   prepare_test_1();
> }
> 
> function finishTest(e) {
>   gPrefs.clearUserPref("pfs.datasource.url");
>   finish();
> }
> 
>+// Gets the number of plugin items in the detected list
>+function getListCount() {
>+  var list = gPFS.document.getElementById("pluginList");
>+  return list.childNodes.length;
>+}
>+
>+// Gets wether the list contains a particular plugin name
>+function hasListItem(name, version) {
>+  var label = name + " " + (version ? version : "");
>+  var list = gPFS.document.getElementById("pluginList");
>+  for (var i = 0; i < list.childNodes.length; i++) {
>+    if (list.childNodes[i].label == label)
>+      return true;
>+  }
>+  return false;
>+}
nit: does the label really have a space after the name when the version is null? If so, perhaps a followup bug to clean this up?

How does this fix the Bug 487717 where there was a timeout?

r=me
(Assignee)

Comment 7

10 years ago
(In reply to comment #6)
> nit: does the label really have a space after the name when the version is
> null? If so, perhaps a followup bug to clean this up?

Sadly yes, filed bug 488712

> How does this fix the Bug 487717 where there was a timeout?
> 
> r=me

Misread that, I'll reopen that and look into it further.
Still a problem :(

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1239909831.1239917951.4166.gz&fulltext=1
WINNT 5.2 mozilla-central unit test on 2009/04/16 12:23:51
(Assignee)

Comment 10

10 years ago
(In reply to comment #9)
> Still a problem :(
> 
> http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1239909831.1239917951.4166.gz&fulltext=1
> WINNT 5.2 mozilla-central unit test on 2009/04/16 12:23:51

This is just bustage from bug 480427 that has since had a fix landed.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Hopefully, this will fix Linux SeaMonkey which had this bug almost constantly since

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1242160999.1242168904.2949.gz
Linux comm-central unit test on 2009/05/12 13:43:19
Flags: in-testsuite+
Target Milestone: --- → mozilla1.9.2a1
Whiteboard: [orange]
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.