[IDE] Undo stack of editor cleared when running a test (save, save as)

VERIFIED FIXED

Status

Testing Graveyard
Mozmill
P2
critical
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

({dataloss})

Trunk
dataloss

Details

(Whiteboard: [mozmill-future][mozmill-1.4.2])

(Reporter)

Description

9 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090408 Shiretoko/3.5b4pre ID:20090408030745 and MozMill trunk.

When you make some modifications to a test and wanna run it to check if the new code also works, there is no way to restore the old content. When running the test it's getting saved and overwrites to former content.

That's a bad dataloss bug which forces me to write a bunch of old code again now.

Please don't clear the undo stack when saving a test.
(Reporter)

Comment 1

9 years ago
Doesn't block writing tests but is really annoying when using the internal editor. Would be great if this can be fixed => P2.
Priority: -- → P2
Whiteboard: [mozmill-future]
(Reporter)

Updated

9 years ago
Summary: Undo stack of editor cleared when running a test (save, save as) → [IDE] Undo stack of editor cleared when running a test (save, save as)
(Reporter)

Comment 2

9 years ago
Heather, I believe that this bug will also be fixed with the move to Bespin, right?
Yes, it will be fixed.
Depends on: 530935
Not fixed with move to Bespin, sorry I didn't fully understand the problem before. The problem is how we load the tests. Right now we save the file and load the file using loadSubScript. We could instead just save to a temp file and load that. I think we should wait until 2.0 to do this though.
(Reporter)

Comment 5

8 years ago
No, this bug is fixed now with the move to Bespin. Cmd/Ctrl+Z works fine after you have run a test from within the IDE. The problem before was, that this shortcut didn't worked. Marking as fixed. Wohooo!
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: [mozmill-future] → [mozmill-future][mozmill-1.4.2]
(In reply to comment #5)
> No, this bug is fixed now with the move to Bespin. Cmd/Ctrl+Z works fine after
> you have run a test from within the IDE. The problem before was, that this
> shortcut didn't worked. Marking as fixed. Wohooo!

Not for me. Trying this out in 1.4.2b3.

STR: 

1. Open a file
2. Make a change.
3. Hold down Cmd/Ctrl+Z

I get a cleared editor right after my change is undone.

Reopening
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 7

8 years ago
(In reply to comment #6)
> 1. Open a file
> 2. Make a change.
> 3. Hold down Cmd/Ctrl+Z
> 
> I get a cleared editor right after my change is undone.

This reported behavior is not part of this bug. Please file that as a separate one.

To verify this one do:
1. Create or load a test
2. Make modifications to the test
3. Run the test
4. Try to undo the modifications

Step 4 didn't work before.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
This bug is verified fixed with the str in comment #7.

As for the other issue

Look's like a regression, as it was once fixed in bug 480247
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.