Dropping attachment containing & in their name don't respect the original name

RESOLVED DUPLICATE of bug 485514

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 485514
9 years ago
9 years ago

People

(Reporter: Vivian De Smedt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090223 Thunderbird/3.0b2 ThunderBrowse/3.2.3

If you have a mail that contains an attachment file which contains a '&' character it its name when you try to detach that attachment by dropping the file to a folder Thunderbird rename the file to drop. Actually it remove the part after the first '&'.

e.g. Suppose you have a mail with a 'tom&jerry.txt' attachment. If you drop 'tom&jerry.txt' in a folder you'll get a 'tom' file in your folder and not a 'tom&jerry.txt' file in it. The content of the file is correct however.

Regards,
Vivian De Smedt.

Reproducible: Always

Steps to Reproduce:
1. Sent a mail containing a attachment that contains a '&' in its name (e.g. 'tom&jerry.txt')
2. When you get the mail in Thunderbird open it and drop the attachment in a folder (e.g. The desktop)

Actual Results:  
The attachment is in the folder but its name is changed (e.g. in 'tom' in our example)

Expected Results:  
The attachment you have been named 'tom&jerry.txt'
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 485514
You need to log in before you can comment on or make changes to this bug.