Closed Bug 487602 Opened 11 years ago Closed 11 years ago

Failed to compile firefox on Solaris

Categories

(Firefox Build System :: General, defect)

All
Solaris
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ginnchen+exoracle, Assigned: ginnchen+exoracle)

References

Details

Attachments

(1 file, 1 obsolete file)

2.03 KB, patch
benjamin
: review+
Details | Diff | Splinter Review
The error message is
configure: syntax error at line 2098: `AS="$(cd "$' unexpected
Attached patch patch (obsolete) — Splinter Review
I didn't try it on Windows yet.

BTW: What's the different of MOZ_PATH_PROG and MOZ_PATH_PROGS?
Assignee: nobody → ginn.chen
Status: NEW → ASSIGNED
Attachment #371842 - Flags: review?(benjamin)
Comment on attachment 371842 [details] [diff] [review]
patch

The same as whatever the difference is between AC_PATH_PROG and AC_PATH_PROGS, but I don't know the details.
Attachment #371842 - Flags: review?(benjamin) → review+
Pushed:
http://hg.mozilla.org/mozilla-central/rev/cf63fe2d4410
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
back out due to red on Windows
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Duplicate of this bug: 488258
Attached patch patch v2Splinter Review
Verified on Windows and Solaris.
I don't know how to make it simpler.
Attachment #371842 - Attachment is obsolete: true
Attachment #372596 - Flags: review?(benjamin)
Status: REOPENED → ASSIGNED
Attachment #372596 - Flags: review?(benjamin) → review+
http://hg.mozilla.org/mozilla-central/rev/e33f765a54cf
Status: ASSIGNED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.