Status

()

Toolkit
XUL Widgets
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Neil Deakin, Assigned: Neil Deakin)

Tracking

unspecified
x86
Mac OS X
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
A number of tests in toolkit/content/tests have been disabled due to issues with them not working on certain platforms. This patch fixes these.

- Bug 474149, two problems: change to not use box objects for the screen coordinates as they round differently, and a screen size issue on Mac when the dock is positioned along the bottom
- Bug 416390, works on the tryserver over 3 attempts. It may be the same issue as 212750.
- Bug 212750, I think margins/borders on some native themes are interfering, so adjust so that mouse events are fired a bit more offset on items
- Bug 409242, changes from that bug seem to work
(Assignee)

Comment 1

9 years ago
Created attachment 371875 [details] [diff] [review]
fix tests
Attachment #371875 - Flags: review?
Attachment #371875 - Flags: review? → review+
Comment on attachment 371875 [details] [diff] [review]
fix tests

all passed on my mac, fwiw
Backed out because it caused windows a test failure:

714 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/modules/plugin/test/test_wmode.xul | Windows does not support windowed plugins (yet) - got true, expected false
(Assignee)

Comment 4

9 years ago
(In reply to comment #3)
> Backed out because it caused windows a test failure:
> 
> 714 ERROR TEST-UNEXPECTED-FAIL |
> chrome://mochikit/content/chrome/modules/plugin/test/test_wmode.xul | Windows
> does not support windowed plugins (yet) - got true, expected false

Huh? Bug 485120 is clearly the problem here and Jim had even already checked in a fix for it. It also has the right failure window, whereas my patch passed test_wmode.xul on its first run. In addition, my patch only affects tests, and only a test that runs after test_wmode.xul

I'm not really clear why this was done, but this patch needs to be checked back in again.
Er, sorry.  I pasted the wrong line from the error log.  The correct error (the one caused by this patch) is:

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/base/content/test/browser_ctrlTab.js | Exception thrown - [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIDOMLocation.toString]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://mochikit/content/browser-test.js :: test_is :: line 135"  data: no]

Had you bothered to look at the tinderbox logs from when you checked in the patch, you would have seen that, of course.
I should also note that given that YOU were the scheduled sheriff yesterday, you're not exactly in a position to complain about people getting the tree green again after your very own checkin...  But I'm not going to spend the half-day and two hours past when I should have been asleep that I spent on this against you.
(Assignee)

Comment 7

9 years ago
(In reply to comment #5)
> TEST-UNEXPECTED-FAIL |
> chrome://mochikit/content/browser/browser/base/content/test/browser_ctrlTab.js
> | Exception thrown - [Exception... "Component returned failure code: 0x80004003
> (NS_ERROR_INVALID_POINTER) [nsIDOMLocation.toString]"  nsresult: "0x80004003
> (NS_ERROR_INVALID_POINTER)"  location: "JS frame ::
> chrome://mochikit/content/browser-test.js :: test_is :: line 135"  data: no]

That was also caused by a different patch.

Anyway, I checked in the patch for this bug again, unchanged, and it caused no test failures.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

9 years ago
Duplicate of this bug: 409242
(Assignee)

Updated

9 years ago
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.