The default bug view has changed. See this FAQ.

Better faster annotate left out the id on line numbers, so links with anchors don't scroll

RESOLVED FIXED

Status

Developer Services
Mercurial: hg.mozilla.org
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: philor, Assigned: philor)

Tracking

({regression})

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
STR:
1. Crash repeatedly
2. ctrl+click several of the source links in http://crash-stats.mozilla.com/report/index/3bf46c00-7570-4fac-ba93-12aea2090409
3. Visit each tab, wondering why you are at the top of the file instead of scrolled to a particular line

Looks like the bug 459823 changeover just forgot to bring along the |id="#lineid#"| on |<a class="codeline" href="##lineid#"|.
(Assignee)

Updated

8 years ago
Blocks: 459823
(Assignee)

Comment 1

8 years ago
Created attachment 372262 [details] [diff] [review]
Fix v.1

Untested, because once I try your instructions (a la bug 459823 comment 16) I always remember that they don't actually work, but I always forget what you have to do instead to make it work.
Assignee: nobody → philringnalda
Status: NEW → ASSIGNED
Attachment #372262 - Flags: review?(ted.mielczarek)
http://armenzg.blogspot.com/2008/12/setup-your-own-hg-local-repo-with.html has good directions. Should put that on a wiki page somewhere.
Attachment #372262 - Flags: review?(ted.mielczarek) → review+
(Assignee)

Comment 3

8 years ago
Good, but a touch excessive for "I just want to tweak a template a tiny bit": the only two things missing from your instructions if you don't need pushlog are

clone http://hg.mozilla.org/users/bsmedberg_mozilla.com/hgpoller/

in mozilla-central/.hg/hgrc include
[extensions]
buglink = {path to hgpoller clone}/buglink.py
(Assignee)

Comment 4

8 years ago
http://hg.mozilla.org/hg_templates/rev/f51076b127ba
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Depends on: 491381
Product: mozilla.org → Release Engineering

Comment 5

3 years ago
https://hg.mozilla.org/hgcustom/version-control-tools/rev/ba10f09ab622
Product: Release Engineering → Developer Services
You need to log in before you can comment on or make changes to this bug.