Cookie not sent(?) when first loading home page

VERIFIED DUPLICATE of bug 48255

Status

()

Core
Networking: Cookies
P3
normal
VERIFIED DUPLICATE of bug 48255
18 years ago
17 years ago

People

(Reporter: James Stangler, Assigned: Stephen P. Morse)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.12-20smp i686; en-US; m17) Gecko/20000807
BuildID:    2000080712

I'm not exactly sure if it's a cookie problem or not, but I'll try to describe
it well enough that someone can diagnose it.
My home page is <http://my.yahoo.com>.  With Netscape 4.7, it loads the "My
Yahoo! for jastangler" page (it knows me because of a cookie that's sent).  When
I launch mozilla, it loads the Yahoo sign-in page because (I'm assuming) the
cookie isn't being sent.  It pre-populates the user and password fields properly
from the password file, but if I click "Sign-in", it still returns the Yahoo
sign-in page.  If I click on the location in the location bar and hit return,
then it properly gets the correct page sent from Yahoo.

Reproducible: Always
Steps to Reproduce:
1.  Find someone with a my.yahoo.com account.
2.  Set your home page to be my.yahoo.com.
3.  Sign-in to my.yahoo.com (it should set a cookie).
4.  Exit mozilla.
5.  Launch mozilla (it should display the sign-in screen instead of the
logged-in screen).  Netscape 4.7 will display the logged-in screen.

Actual Results:  My Yahoo returns the sign-in page instead of the logged-in page.

Expected Results:  The logged-in page should have been returned.
(Assignee)

Comment 1

18 years ago
The part about hitting the return and getting to the correct page is a dup 
of 48255.

If some of the other symptoms occur only on the first launch after an install 
(reporter wasn't clear about that), it might also be related to bug 46989 which 
has just been fixed.

*** This bug has been marked as a duplicate of 48255 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.