Bustage fix for Linux mobile composite plugins

RESOLVED FIXED

Status

()

Core
Plug-ins
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: mfinkle, Assigned: mfinkle)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 372052 [details] [diff] [review]
patch

A recent checkin for plugins must have changed headers enough to cause a problem in nsPluginNativeWindowGTK2.cpp

This patch adds back a header needed for composite plugins on Linux mobile builds.
Attachment #372052 - Flags: review?(joshmoz)

Comment 1

9 years ago
Comment on attachment 372052 [details] [diff] [review]
patch

That header shouldn't be used there (afaict) but it is, we'll have to fix that code later.

The problem is that the code depended on the headers that were ifdef OJI.
Attachment #372052 - Flags: review?(joshmoz) → review+

Comment 2

9 years ago
I pushed this to mozilla-central to clear the tree ASAP

http://hg.mozilla.org/mozilla-central/rev/2bf41fa8189d
Assignee: nobody → mark.finkle
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Jeff/Vlad - just an FYI. With the XPCOM interfaces going away, we should probably switch to npapi methods to do this.

Romaxa - this should fix a build problem you saw at one point too.
You need to log in before you can comment on or make changes to this bug.