"Save As" creates a new empty tab in the editor

VERIFIED FIXED

Status

Testing Graveyard
Mozmill
P4
normal
VERIFIED FIXED
9 years ago
a year ago

People

(Reporter: aakashd, Assigned: Adam Christian)

Tracking

({regression})

Details

(Whiteboard: [verified-mozmill-1.2])

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Created attachment 372078 [details]
SavedAs_Before_Screenshot

Build: MozMill 1.1

A new file is created onto the editor to the left of the Saved file when using the "Save As" command. Before and After screen sh


Steps to Reproduce:
1. Open MozMill 1.1
2. Go to Test|Save As


Actual Results:
A new file is created to the left of the saved file.

Expected Results:
A new file should not be created when using the "Save as" command.
(Reporter)

Comment 1

9 years ago
Created attachment 372079 [details]
SavedAs_After_Screenshot
It has to create a new file when you run this command. But it shouldn't create a new empty tab while doing this command.

P4 - it doesn't stop us in writing tests in any way.
Priority: -- → P4
Summary: "Save As" creates a new file → "Save As" creates a new empty tab in the editor
Somehow this regressed again after my bug 480872 was fixed. Strange.
Blocks: 480872
Keywords: regression
Whiteboard: [mozmill-1.2]
(Assignee)

Comment 4

9 years ago
I had a long rant about why we should push this, but it was easier to just fix it: Committed revision 450.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Verified fixed with r451.
Assignee: nobody → adam.christian
Status: RESOLVED → VERIFIED
Whiteboard: [mozmill-1.2] → [verified-mozmill-1.2]
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.