JPEG image rendered in wrong colours

RESOLVED DUPLICATE of bug 497363

Status

()

RESOLVED DUPLICATE of bug 497363
10 years ago
10 years ago

People

(Reporter: tswsl1989, Unassigned)

Tracking

1.9.1 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3

The image at the top of the page appears in the wrong colours. It's not quite inverted, but similar.

Have cleared cache and restarted firefox. No change. Image appears the same when viewed from photobucket. Isn't an issue with 3.0.8
Also happened when image downloaded and viewed using file:///path/to/image.jpg

Reproducible: Always

Steps to Reproduce:
1.Visit URL given
2.Check at http://img.photobucket.com/albums/v120/jewel944/Av%20and%20Sig%20pics/LENFlag7.jpg
Actual Results:  
Image rendered in wrong colours


Expected Results:  
Image to be displayed with a brown background, silver shield.

Fedora 10 i686, fully up to date. Installed 3.1b3 today. Weave and colourful tabs installed
(Reporter)

Comment 1

10 years ago
Created attachment 372094 [details]
This is the image from the URL given

Comment 2

10 years ago
Works for Me, might be to do with color profile correction which is on by default in 3.1b3
Also the attachment looks correct here too which indicates an incorrect system profile on your monitor.
Possibly related to bug 460629
Thomas, to verify this, you can use https://addons.mozilla.org/en-US/firefox/addon/6891 to turn it on in 3.0.8
Test page is at http://www.color.org/version4html.xalter
(Reporter)

Comment 3

10 years ago
If I enable colour profile correction in 3.0.8 then I see the same problem, but on a lot more images. I'll try and change colour profiles and see if that works.
(Reporter)

Comment 4

10 years ago
I haven't been able to work out what profile my system is currently using, but setting gfx.color_management.mode to 0 makes images display correctly again.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 460629

Updated

10 years ago
Component: General → GFX: Color Management
Product: Firefox → Core
Version: unspecified → 1.9.1 Branch

Updated

10 years ago
Duplicate of bug: 497363
You need to log in before you can comment on or make changes to this bug.