Sporadic "make check" timeout after toolkit/components/downloads/test/unit/test_bug_401582.js

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
RESOLVED WORKSFORME
9 years ago
5 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86
Windows Server 2003
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
The windows mozilla-central unit test box just went orange due to a timeout (300 sec without output) in "make check".  Here's a snippet of output:

TEST-PASS | e:\builds\moz2_slave\mozilla-central-win32-unittest\build\objdir\_tests\xpcshell\test_dm\unit\test_bug_401582.js | all tests passed

command timed out: 300 seconds without output
program finished with exit code 1
TinderboxPrint: check<br/>532/0
buildbot.slave.commands.TimeoutError: command timed out: 300 seconds without output
TinderboxPrint: check<br/><em class="testfail">timeout</em>

Note that the next test to run (and therefore the test that was probably running when it timed out?) would be
http://mxr.mozilla.org/mozilla-central/source/toolkit/components/downloads/test/unit/test_bug_406857.js

There were two new changesets built in the orange cycle:
  http://hg.mozilla.org/mozilla-central/rev/4da51fbf7245
  http://hg.mozilla.org/mozilla-central/rev/b0c75eac0898
but sdwilsh says he's 100% sure those changesets aren't related to the orange.
(Reporter)

Updated

9 years ago
Whiteboard: [orange]
(Reporter)

Comment 1

9 years ago
I put the failing tinderbox-log in the URL field, but I forgot to mention it in the initial description.  Here it is:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1239386914.1239395947.18838.gz
WINNT 5.2 mozilla-central unit test on 2009/04/10 11:08:34
And xpcshell-tests passed:

TEST-PASS | e:\builds\moz2_slave\mozilla-central-win32-unittest\build\objdir\_tests\xpcshell\test_dm\unit\test_bug_401582.js | all tests passed
TEST-PASS | e:\builds\moz2_slave\mozilla-central-win32-unittest\build\objdir\_tests\xpcshell\test_dm\unit\test_bug_406857.js | all tests passed
OS: Linux → Windows Server 2003
Created attachment 391825 [details] [diff] [review]
[checked in] Add some debugging

We are frequently seeing this timeout on the Thunderbird tinderboxes. I've taken a look and test_bug_406587.js is most likely the culprit. As I can't reproduce, I'd like to add some extra info to try and work out what is happening.

This patch adds checks for the download being cancelled (yes, unlikely) or failing (possible). If it fails we'll at least abort the test and know what is happening.

I'm tempted to add a timeout as well, but lets try this in the first instance.
Attachment #391825 - Flags: review?(sdwilsh)
Comment on attachment 391825 [details] [diff] [review]
[checked in] Add some debugging

r=sdwilsh
Attachment #391825 - Flags: review?(sdwilsh) → review+
For some reason this bug has got really worse over the last day or so. The tree is closed and I'm off to bed, but if anyone wants to land it to get some more diagnosis, please feel free to do so.
Keywords: checkin-needed
Comment on attachment 391825 [details] [diff] [review]
[checked in] Add some debugging

Given how bad this has got over the last day or so, I just checked this in:

http://hg.mozilla.org/mozilla-central/rev/e75bc8b91b26

Hopefully we'll get a better idea of what is failing.
Attachment #391825 - Attachment description: Add some debugging → [checked in] Add some debugging
Keywords: checkin-needed

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

5 years ago
Keywords: intermittent-failure
(Assignee)

Updated

5 years ago
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.