Closed Bug 487885 Opened 12 years ago Closed 12 years ago

Add spam filtering to mailman's gate_news script

Categories

(mozilla.org Graveyard :: Server Operations, task, P1)

task

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: reed, Assigned: reed)

References

()

Details

Most of our spam to the newsgroup mailing lists comes in from the NNTP side, as mailman's gate_news script doesn't do any spam filtering. We should add SpamAssassin, SpamBayes, or something filtering to it.

Skip Montanaro has a bzr branch for SpamBayes support that includes modifications to gate_news, so hopefully that will help as a starting point.
Tagging as a Q2 goal. I don't see myself getting to this until May at the earliest, though.
Priority: -- → P2
I'm curious.
Is someone making progress towards this goal?
Or is it perhaps the case that mailman's message size limit has always 
applied to messages from news as well as from email? 

This morning, there appeared in the dev-tech-crypto alias moderation queue 
a 60KB spam that apparently originated as a news posting.  It was filtered
into the moderation queue because its size exceeded the limit imposed on 
messages to that list (which has been 40KB for at least 5 years now).

I don't recall ever seeing that phenomenon before, a news posting stopped
for being too big.  Is that a sign of progress?  Or just an occurrence of 
a rare event?
Component: Server Operations: Projects → Server Operations
ETA?
Bumping up.  Was supposed to be something done in Q2.
Severity: major → critical
Priority: P2 → P1
After some discussions with the current mailman 2.x maintainer, I changed my mind about adding this to gate_news and went another path instead.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
The changes that have been recently made to lists.mozilla.org to attempt to 
do spam filtering have broken a fundamental capability of that list server.
Whenever a message is flagged as spam by spam assasin, it goes into the 
moderation queue, EVEN IF the list owner has configured the list to DISCARD
all emails from non-list subscribers.  So, the option to discard all email 
from non-subscribers no longer works.  

This is a big regression.
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.