file|open dialog appears in second unplagged display

VERIFIED DUPLICATE of bug 295540

Status

()

Firefox
Menus
VERIFIED DUPLICATE of bug 295540
9 years ago
9 years ago

People

(Reporter: Antony Tkachov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; uk; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; uk; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8

file|open dialog appears in second display (if that was last time) even if it unplugged and uncheked in Windows Display Options dialog.

Reproducible: Always

Steps to Reproduce:
1. Run PC with plugged and activated second display as widening desktop (not in clone).
2. Open FF3 in primary display. Use Menu - File - Open dialog or button in site with Browse option.
3. Drag Open dialog window to second display and choose any file. FF3 remember window coordinates.
4. Unplug second display. Physically. Or wait for eco-mode of PC (i use netbook). You can uncheck second display option in Windows dialog.
5. Set focus to FF3 and press another one time browse button or select menu - file - open... FF3 did check coordinates and open window in hidden space of desktop. Esc return to work main window
Actual Results:  
I can`t even after rebooting FF3 use this dialog.

Expected Results:  
1. Check active display
2. If coordinates of last time using option is hidden rewrite it to center of main screen and open window in new place.

MSI Wind u100, any additional monitor (acer AL1717, Samsung 19")
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 295540
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.