Extra newlines from line wrapping copied to clipboard (Thunderbird in windows)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
10 years ago
5 years ago

People

(Reporter: tempmail, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.2) Gecko/2008090514 Firefox/3.0.2 (.NET CLR 3.5.30729)
Build Identifier: 2.0.0.21

This is reported for mail composition and for Firefox, but not for email reading.
The following was sent as a single line of code with no new line after "adc:" :
-----------------------------------------------------------------------------
        'OUT_vMuxedAddr',dec2bin(6,3),... % connects Vs_Mon0 to adc:
NS_ReadADC('VMM_Muxed')
------------------------------------------------------------------------------
The above text should have been a single line of code with a comment at the end.  Line wrapping turned it into two lines (the space after the colon was lost pasting here (using firefox) but was maintained in notepad along with the false newline). 

Reproducible: Always

Steps to Reproduce:
1.Recieve an email with a long line that has spaces in it
2.Read email and notice line wrapping
3.Copy line, including wrapped portion
4.Paste in text editor like notepad.exe.  Wrapping-generated newline shows up as a new newline
Actual Results:  
two lines

Expected Results:  
one line

Copying and pasting from the exact same email using gmail (in Firefox) worked correctly (only one line even where line wrapping occurs)
Ryan, can your reproduce with v5 or v6?
Whiteboard: [closeme 2011-09-01]
RESOLVED INCOMPLETE due to lack of response to previous question. If you feel this change was in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

7 years ago
I have not been able to reproduce the problem in version 6.
OS: Windows Vista → Windows 7
Resolution: INCOMPLETE → WORKSFORME
(Reporter)

Comment 4

7 years ago
I take that back.  I forgot that the incoming email must be a plain text email (I should have mentioned that in my step 1), otherwise Thunderbird will not apply the word wrap when viewing.  The problem does exist the same as before
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(In reply to Ryan from comment #4)
> I take that back.  I forgot that the incoming email must be a plain text
> email (I should have mentioned that in my step 1), otherwise Thunderbird
> will not apply the word wrap when viewing.  The problem does exist the same
> as before
Whiteboard: [closeme 2011-09-01]
There is something going on with the character sequence colon, space.
Here are my steps to reproduce:
Format flowed set to true
Plaintext compose

1 Start typing a line of text
2 include the sequence colon, space
3 continue to type until you exceed the wrap length (default=72)
4 notice that the line wraps at the colon, space point after 72 characters

View the source to see that text has been wrapped at the colon space point.
Actual viewing with format flowed covers the line wrap up due to the trailing space (I presume)

So is the sequence colon, space being interpreted as a soft line break?

Seems to be a valid bug to me.
Tested with:
Mozilla/5.0 (Windows NT 5.0; rv:9.0a1) Gecko/20110901 Thunderbird/9.0a1 ID:20110901030233
Similar to bug 362194.

does this still happen in TB12?
Flags: needinfo?
(In reply to Thomas D. from comment #8)
> Similar to bug 362194.
> 
> does this still happen in TB12?
Flags: needinfo?(tempmail)
Flags: needinfo?(jsabash)
Flags: needinfo?
Unable to reproduce with my steps in comment 6  (Current trunk)
Flags: needinfo?(jsabash)
Thanks Joe.  WFM also.

Feel free to try bug 362194.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago5 years ago
Flags: needinfo?(tempmail)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.