enable-static disable-shared fails to link

RESOLVED DUPLICATE of bug 488019

Status

MailNews Core
Build Config
RESOLVED DUPLICATE of bug 488019
9 years ago
9 years ago

People

(Reporter: Tuukka Tolvanen (sp3000), Unassigned)

Tracking

1.9.1 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
linux, comm-central, mozilla-1.9.1. Looks like I had the last successful build at around 2009-04-07-08Z and first fail at 2009-04-12-10Z. I guess I'll blame something in the ballpark of bug 487252 / bug 481926 with a dash of bug 453920, as no interesting sw updates happened in the interim.

ccache g++ -o thunderbird-bin  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-long-long -pedantic -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -Os -freorder-blocks -fno-reorder-functions   nsMailApp.o nsStaticComponents.o    -lpthread   -Wl,-rpath-link,../../mozilla/dist/bin:/usr/lib:/usr/local/lib:/lib  -L../../mozilla/dist/bin -L../../mozilla/dist/lib ../../mozilla/toolkit/xre/libxulapp_s.a -L../../mozilla/staticlib -L../../mozilla/dist/bin -lmozjs  -L../../mozilla/dist/bin -lxpcom -lxpcom_core  `../../mozilla/nsprpub/config/nspr-config --prefix=../../mozilla/dist --libdir=../../mozilla/dist/lib --libs` -lgtk-x11-2.0 -latk-1.0 -lpangoft2-1.0 -lfreetype -lz -lfontconfig -lgdk-x11-2.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lgio-2.0 -lpango-1.0 -lcairo -lgmodule-2.0 -lgobject-2.0 -lglib-2.0      -lX11  -L//lib -ldbus-glib-1 -ldbus-1 -lgobject-2.0 -lglib-2.0   -Wl,--whole-archive -ljemalloc -Wl,--no-whole-archive -ldl -lm  ../../mozilla/staticlib/components/libpref.a ../../mozilla/staticlib/components/libuconv.a ../../mozilla/staticlib/components/libucvmath.a ../../mozilla/staticlib/components/libi18n.a ../../mozilla/staticlib/components/libnecko.a ../../mozilla/staticlib/components/libauth.a ../../mozilla/staticlib/components/libxpconnect.a ../../mozilla/staticlib/components/libchardet.a ../../mozilla/staticlib/components/libzipwriter.a ../../mozilla/staticlib/components/libmork.a ../../mozilla/staticlib/components/libcookie.a ../../mozilla/staticlib/components/libpermissions.a ../../mozilla/staticlib/components/libstoragecomps.a ../../mozilla/staticlib/components/librdf.a ../../mozilla/staticlib/components/libcaps.a ../../mozilla/staticlib/components/libhtmlpars.a ../../mozilla/staticlib/components/libgkgfxthebes.a ../../mozilla/staticlib/components/libimglib2.a ../../mozilla/staticlib/components/libgkplugin.a ../../mozilla/staticlib/components/libwidget_gtk2.a ../../mozilla/staticlib/components/libtxmgr.a ../../mozilla/staticlib/components/libcomposer.a ../../mozilla/staticlib/components/libgklayout.a ../../mozilla/staticlib/components/libdocshell.a ../../mozilla/staticlib/components/libembedcomponents.a ../../mozilla/staticlib/components/libwebbrwsr.a ../../mozilla/staticlib/components/libnsappshell.a ../../mozilla/staticlib/components/libuniversalchardet.a ../../mozilla/staticlib/components/libaccessibility.a ../../mozilla/staticlib/components/libchrome.a ../../mozilla/staticlib/components/libmozfind.a ../../mozilla/staticlib/components/libintlapp.a ../../mozilla/staticlib/components/libwindowds.a ../../mozilla/staticlib/components/libxpautocomplete.a ../../mozilla/staticlib/components/libremoteservice.a ../../mozilla/staticlib/components/libfileview.a ../../mozilla/staticlib/components/libtkautocomplete.a ../../mozilla/staticlib/components/libcommandlines.a ../../mozilla/staticlib/components/libtoolkitcomps.a ../../mozilla/staticlib/components/libspellchecker.a ../../mozilla/staticlib/components/libunixproxy.a ../../mozilla/staticlib/components/libpipboot.a ../../mozilla/staticlib/components/libpipnss.a ../../mozilla/staticlib/components/libpippki.a ../../mozilla/staticlib/components/libautoconfig.a ../../mozilla/staticlib/components/libsystem-pref.a ../../mozilla/staticlib/components/libmozldap.a ../../mozilla/staticlib/components/libimport.a ../../mozilla/staticlib/components/libmsgsmime.a ../../mozilla/staticlib/components/libmail.a ../../mozilla/staticlib/components/libmailcomps.a ../../mozilla/staticlib/libmozreg_s.a ../../mozilla/staticlib/libunicharutil_s.a ../../mozilla/staticlib/libucvutil_s.a ../../mozilla/staticlib/libgtkxtbin.a ../../mozilla/staticlib/libthebes.a ../../mozilla/staticlib/libgfxshared_s.a ../../mozilla/staticlib/libgfxpsshar.a ../../mozilla/staticlib/libgkgfx.a ../../mozilla/staticlib/libmimecthglue_s.a  -L../../mozilla/modules/libimg/png -lmozpng -L../../mozilla/jpeg -lmozjpeg -L../../mozilla/modules/zlib/src -lmozz    -L../../mozilla/dist/bin -L../../mozilla/dist/lib -lcrmf -lsmime3 -lssl3 -lnss3 -lnssutil3 -lsoftokn3  -L../../mozilla/dist/bin -L../../mozilla/dist/lib -lldap60 -lprldap60 -lldif60  ../../mozilla/gfx/cairo/cairo/src/libmozcairo.a ../../mozilla/gfx/cairo/libpixman/src/libmozlibpixman.a   -lXrender -lfreetype -lfontconfig  -lXt -lgthread-2.0 -lpangoft2-1.0 -lpango-1.0 -lfreetype -lz -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lglib-2.0   -L../../mozilla/dist/lib -lsqlite3    
../../mozilla/staticlib/components/libimglib2.a(nsPNGDecoder.o): In function `row_callback(png_struct_def*, unsigned char*, unsigned long, int)':
nsPNGDecoder.cpp:(.text+0x444): undefined reference to `cmsDoTransform'
nsPNGDecoder.cpp:(.text+0x782): undefined reference to `cmsDoTransform'
../../mozilla/staticlib/components/libimglib2.a(nsPNGDecoder.o): In function `PNGGetColorProfile(png_struct_def*, png_info_struct*, int, unsigned int*, unsigned int*)':
nsPNGDecoder.cpp:(.text+0x9fe): undefined reference to `cmsCreate_sRGBProfile'
nsPNGDecoder.cpp:(.text+0xa78): undefined reference to `cmsOpenProfileFromMem'
nsPNGDecoder.cpp:(.text+0xa82): undefined reference to `cmsGetColorSpace'
nsPNGDecoder.cpp:(.text+0xaa2): undefined reference to `cmsCloseProfile'
nsPNGDecoder.cpp:(.text+0xaed): undefined reference to `cmsTakeRenderingIntent'
nsPNGDecoder.cpp:(.text+0xb06): undefined reference to `cmsGetColorSpace'
nsPNGDecoder.cpp:(.text+0xc0e): undefined reference to `cmsBuildGamma'
nsPNGDecoder.cpp:(.text+0xc2e): undefined reference to `cmsCreateRGBProfile'
nsPNGDecoder.cpp:(.text+0xc50): undefined reference to `cmsFreeGamma'
../../mozilla/staticlib/components/libimglib2.a(nsPNGDecoder.o): In function `info_callback(png_struct_def*, png_info_struct*)':
nsPNGDecoder.cpp:(.text+0xf05): undefined reference to `cmsCreateTransform'
../../mozilla/staticlib/components/libimglib2.a(nsPNGDecoder.o): In function `nsPNGDecoder::~nsPNGDecoder()':
nsPNGDecoder.cpp:(.text+0x1452): undefined reference to `cmsCloseProfile'
nsPNGDecoder.cpp:(.text+0x1465): undefined reference to `cmsDeleteTransform'
../../mozilla/staticlib/components/libimglib2.a(nsPNGDecoder.o): In function `nsPNGDecoder::~nsPNGDecoder()':
nsPNGDecoder.cpp:(.text+0x14da): undefined reference to `cmsCloseProfile'
nsPNGDecoder.cpp:(.text+0x14ed): undefined reference to `cmsDeleteTransform'
../../mozilla/staticlib/components/libimglib2.a(nsPNGDecoder.o): In function `nsPNGDecoder::~nsPNGDecoder()':
nsPNGDecoder.cpp:(.text+0x155a): undefined reference to `cmsCloseProfile'
nsPNGDecoder.cpp:(.text+0x156d): undefined reference to `cmsDeleteTransform'
../../mozilla/staticlib/components/libimglib2.a(nsGIFDecoder2.o): In function `ConvertColormap(unsigned int*, unsigned int)':
nsGIFDecoder2.cpp:(.text+0x33e): undefined reference to `cmsDoTransform'
../../mozilla/staticlib/components/libimglib2.a(nsJPEGDecoder.o): In function `nsJPEGDecoder::OutputScanlines(int*)':
nsJPEGDecoder.cpp:(.text+0x2ea): undefined reference to `cmsDoTransform'
nsJPEGDecoder.cpp:(.text+0x44a): undefined reference to `cmsDoTransform'
../../mozilla/staticlib/components/libimglib2.a(nsJPEGDecoder.o): In function `nsJPEGDecoder::ProcessData(char const*, unsigned int, unsigned int*)':
nsJPEGDecoder.cpp:(.text+0xa9d): undefined reference to `cmsOpenProfileFromMem'
nsJPEGDecoder.cpp:(.text+0xacb): undefined reference to `cmsGetColorSpace'
nsJPEGDecoder.cpp:(.text+0xb68): undefined reference to `cmsCreateTransform'
nsJPEGDecoder.cpp:(.text+0xcbf): undefined reference to `cmsTakeRenderingIntent'
../../mozilla/staticlib/components/libimglib2.a(nsJPEGDecoder.o): In function `nsJPEGDecoder::~nsJPEGDecoder()':
nsJPEGDecoder.cpp:(.text+0x1115): undefined reference to `cmsDeleteTransform'
nsJPEGDecoder.cpp:(.text+0x112b): undefined reference to `cmsCloseProfile'
../../mozilla/staticlib/components/libimglib2.a(nsJPEGDecoder.o): In function `nsJPEGDecoder::~nsJPEGDecoder()':
nsJPEGDecoder.cpp:(.text+0x1195): undefined reference to `cmsDeleteTransform'
nsJPEGDecoder.cpp:(.text+0x11ab): undefined reference to `cmsCloseProfile'
../../mozilla/staticlib/components/libimglib2.a(nsJPEGDecoder.o): In function `nsJPEGDecoder::~nsJPEGDecoder()':
nsJPEGDecoder.cpp:(.text+0x1215): undefined reference to `cmsDeleteTransform'
nsJPEGDecoder.cpp:(.text+0x122b): undefined reference to `cmsCloseProfile'
../../mozilla/staticlib/components/libwidget_gtk2.a(nsXPLookAndFeel.o): In function `nsXPLookAndFeel::GetColor(nsILookAndFeel::nsColorID, unsigned int&)':
nsXPLookAndFeel.cpp:(.text+0x6af): undefined reference to `cmsDoTransform'
../../mozilla/staticlib/libthebes.a(gfxPlatform.o): In function `gfxPlatform::GetCMSsRGBProfile()':
gfxPlatform.cpp:(.text+0xb1): undefined reference to `cmsCreate_sRGBProfile'
gfxPlatform.cpp:(.text+0xc0): undefined reference to `cmsPrecacheProfile'
../../mozilla/staticlib/libthebes.a(gfxPlatform.o): In function `gfxPlatform::GetCMSOutputProfile()':
gfxPlatform.cpp:(.text+0x14b): undefined reference to `cmsProfileIsBogus'
gfxPlatform.cpp:(.text+0x16a): undefined reference to `cmsPrecacheProfile'
gfxPlatform.cpp:(.text+0x188): undefined reference to `cmsCloseProfile'
gfxPlatform.cpp:(.text+0x25b): undefined reference to `cmsOpenProfileFromFile'
../../mozilla/staticlib/libthebes.a(gfxPlatform.o): In function `gfxPlatform::GetCMSRGBATransform()':
gfxPlatform.cpp:(.text+0x2b8): undefined reference to `cmsCreateTransform'
../../mozilla/staticlib/libthebes.a(gfxPlatform.o): In function `gfxPlatform::GetCMSInverseRGBTransform()':
gfxPlatform.cpp:(.text+0x30e): undefined reference to `cmsCreateTransform'
../../mozilla/staticlib/libthebes.a(gfxPlatform.o): In function `gfxPlatform::GetCMSRGBTransform()':
gfxPlatform.cpp:(.text+0x364): undefined reference to `cmsCreateTransform'
../../mozilla/staticlib/libthebes.a(gfxPlatform.o): In function `gfxPlatform::TransformPixel(gfxRGBA const&, gfxRGBA&, void*)':
gfxPlatform.cpp:(.text+0x5a1): undefined reference to `cmsDoTransform'
../../mozilla/staticlib/libthebes.a(gfxPlatform.o): In function `ShutdownCMS()':
gfxPlatform.cpp:(.text+0xed5): undefined reference to `cmsDeleteTransform'
gfxPlatform.cpp:(.text+0xef4): undefined reference to `cmsDeleteTransform'
gfxPlatform.cpp:(.text+0xf13): undefined reference to `cmsDeleteTransform'
gfxPlatform.cpp:(.text+0xf32): undefined reference to `cmsCloseProfile'
gfxPlatform.cpp:(.text+0xf5e): undefined reference to `cmsCloseProfile'
../../mozilla/staticlib/libthebes.a(gfxPlatform.o): In function `gfxPlatform::Init()':
gfxPlatform.cpp:(.text+0x1168): undefined reference to `cmsErrorAction'
../../mozilla/staticlib/libthebes.a(gfxPlatformGtk.o): In function `gfxPlatformGtk::GetPlatformCMSOutputProfile()':
gfxPlatformGtk.cpp:(.text+0x306): undefined reference to `cmsOpenProfileFromMem'
gfxPlatformGtk.cpp:(.text+0x4cb): undefined reference to `cmsBuildGamma'
gfxPlatformGtk.cpp:(.text+0x4f4): undefined reference to `cmsCreateRGBProfile'
gfxPlatformGtk.cpp:(.text+0x4ff): undefined reference to `cmsFreeGamma'
/usr/bin/ld: thunderbird-bin: hidden symbol `cmsBuildGamma' isn't defined
/usr/bin/ld: final link failed: Nonrepresentable section on output
collect2: ld:n paluuarvo oli 1
make[5]: *** [thunderbird-bin] Virhe 1
make[5]: Poistutaan hakemistosta "/media/ext/tt/obj/thunderbird/mail/app"
(Reporter)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 488019
You need to log in before you can comment on or make changes to this bug.