Context menu shows unapplicable options after right clicking on empty place on page and then dragging cursor out of window

RESOLVED DUPLICATE of bug 632411

Status

()

Firefox
Menus
--
minor
RESOLVED DUPLICATE of bug 632411
9 years ago
7 years ago

People

(Reporter: laurens2511, Unassigned)

Tracking

3.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; nl; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; nl; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 (.NET CLR 3.5.30729)

The context menu shows options unapplicable to the currently selected item(s).

Reproducible: Always

Steps to Reproduce:
1. Open a new Firefox window   (ex. press Ctrl + N) and wait for it to show your start page.
2. Press the right mouse button when the cursor is on an empty spot of the web page.
3. With the right mouse button still held, drag the cursor out of the window
4. When the cursor is outside the window area, release the right mouse button
Actual Results:  
Firefox then shows the context menu with all ever possible options.
(Add to dictionary, Open link in new window, Open link in new tab, Bookmark this link, Save link as, copy email address, show image, copy image, set as wallpaper, back, forward, refresh, stop, create bookmark for this page, ....)

The actual context menu text which I quote here may differ from the real text because I use a Dutch version of Firefox and translated the options myself.

Expected Results:  
I would expect the software to show the options applicable to the item the cursor was on, on the moment of pressing the right mouse button.

I use the default Firefox theme
Windows Vista Business SP 1 x86
Firefox 3.0.8
(Reporter)

Comment 1

9 years ago
Created attachment 372295 [details]
Screenshot of the bug occuring
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090411 Shiretoko/3.5b4pre (.NET CLR 3.5.30729) ID:20090411045655
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 3.0 Branch

Comment 3

7 years ago
Confirmed, I have the same problem.

Windows 7, 64 bit, Firefox v3.6.13
(Reporter)

Comment 4

7 years ago
Fixed in Firefox 4
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Resolution: FIXED → DUPLICATE
Duplicate of bug: 632411
You need to log in before you can comment on or make changes to this bug.