Closed Bug 488095 Opened 11 years ago Closed 11 years ago

Some XUL files are missing from chrome/messenger.jar

Categories

(MailNews Core :: Build Config, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ZaneUJi, Assigned: mnyromyr)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090413 SeaMonkey/2.0b1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090413 SeaMonkey/2.0b1pre

When I try to send a html email, a window with title "Page load error" pops up. It complains that:
"The file jar:file:///E:/SeaMonkey/chrome/messenger.jar!/content/messenger/messengercompose/askSendFormat.xul cannot be found. Please check the location and try again."
"E:/SeaMonkey" is where I installed SeaMonkey.

Besides askSendFormat.xul, sendProgress.xul is also missing.

Reproducible: Always

Steps to Reproduce:
1.Open the composition window, input some html content.
2.Specify a receiver that hasn't been specified which format (html or text) this receiver prefers.
3.Click "send" and finish spell checking if there is any.
Actual Results:  
An error message dialog will pop up. It reports that a file couldn't be found.

Expected Results:  
An dialog will show up to ask which format should be used to send the email.

Version built on April 9, 2009 doesn't have such problem.
Assignee: nobody → mnyromyr
Status: UNCONFIRMED → ASSIGNED
Component: MailNews: Composition → Build Config
Depends on: 390262
Ever confirmed: true
OS: Windows XP → All
Product: SeaMonkey → MailNews Core
QA Contact: mailnews-composition → build-config
Hardware: x86 → All
Yet another block of missing stuff from the v1 -> v3 transition in bug 390262. :-(

Neil, feel free to check-in, I'll be away for the rest of the day.
Attachment #372383 - Flags: superreview?(neil)
Attachment #372383 - Flags: review?(neil)
Attachment #372383 - Flags: superreview?(neil)
Attachment #372383 - Flags: superreview+
Attachment #372383 - Flags: review?(neil)
Attachment #372383 - Flags: review+
Pushed changeset f7066530f8e7 to comm-central.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Oh, no wonder I missed seeing that sending was broken: it wasn't, for us, because we have a separate jar.mn in mail/components/compose/ that's now jarring them twice (and one in mail/components/addrbook/, and in mail/components/preferences/, and in mail/extensions/smime/ if we take the guard off mailnews/extensions/smime/'s).
Duplicate of this bug: 488098
You need to log in before you can comment on or make changes to this bug.