Symbian Build Problems

RESOLVED FIXED in Future

Status

Tamarin
Build Config
--
enhancement
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Shivakumara, Unassigned)

Tracking

unspecified
Future
Other
Other
Bug Flags:
flashplayer-qrb +
flashplayer-triage +

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8
Build Identifier: Changeset: 1645 5cd73575c334

When the product is compiled for symbian Operating System, using RVCT compiler following are strictly imposed. 
1. The initialization of variables must be in the order of declaration. For eg.GC.h- Line 1638 - gc and unwindPtr must be interchanged. It should look like 
AllocaAutoPtr() : gc(NULL), unwindPtr(NULL) {}
2. The variable number arguments are not permitted for macros. Hence AbcParser.cpp does not compile. 

Reproducible: Always

Steps to Reproduce:
1.Compile the code on RVCT for Symbian OS.

Actual Results:  
The files do not compile.

Expected Results:  
If the changes suggested in the "Details" section are kept in mind while making changes, will help us in integrating the MMGC far easier.

Comment 1

9 years ago
Hrm, nanojit makes use of variable-length macros extensively. Could we just use a better preprocessor instead of the old RVCT one?

Comment 2

9 years ago
At the moment, the Symbian builds in question aren't compiling with nanojit enabled, I think, which is why they haven't encountered these problems. But yes, that's going to be a hard one to work around. Which version(s) of RVCT don't support variadic macros (or rather, are there any later versions that do support them)?

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: flashplayer-triage+
Flags: flashplayer-qrb?

Comment 3

9 years ago
Building and running the avm using the latest Symbian S60 tool chain has been possible for a while. If JIT feature is turned on, building can be done only in Carbide IDE. If the JIT feature is off, building can be done also using the command line tool chain. The JIT is not functional on Symbian yet so try compiling with JIT turned off.

However, I'm aware that there are no proper .mmp files (=Symbian project file) checked in to tamarin so that you could build the avm shell for example.

Comment 4

9 years ago
I was working on trying to get the avmshell building for symbian via RVCT and
posted a first stab at getting the project files in place (bug #499669). I know
that there is still a lot to be done to get it to work. I think that I will
mark #499669 as a dupe of this bug.

Updated

9 years ago
Blocks: 447961

Comment 5

9 years ago
moving to future
Target Milestone: --- → Future

Updated

9 years ago
Flags: flashplayer-qrb? → flashplayer-qrb+

Comment 6

9 years ago
I'm working on avmshell for Symbian.

Updated

9 years ago
Duplicate of this bug: 499669

Comment 8

8 years ago
I'm not aware of the problem Shivakumara mentions. I think this bug can be closed.

Comment 9

8 years ago
I think we've fixed all those problems in the VM - we're requiring proper initialization order on all platforms, and we do not rely on variable argument lists for macros on Symbian.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.