HTML page with Browse button for file uploading crashes browser

VERIFIED DUPLICATE of bug 49010

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED DUPLICATE of bug 49010
18 years ago
17 years ago

People

(Reporter: Kalle Valo, Assigned: rods (gone))

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Overview Description:

Browser crashes if I push the 'Browse' button on a page with upload
functionality. Sometimes just moving the mouse pointer over the button
crashes browser.


Steps to Reproduce:
1) Load page.
2) Press 'Browse' button.

Actual Results:

I started mozilla with ./mozilla --debug and I get segmantation fault.

Program received signal SIGSEGV, Segmentation fault.
0x40e21842 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so

Expected Results:

File dialog should open so file can be selected for upload.

Reproducibility:

Always.

Build Date & Platform Bug Found:

Mozilla/5.0 (X11; U; Linux 2.2.14 i686; en-US; m18) Gecko/20000811

Debian GNU/Linux woody
Linux kernel 2.2.14 SMP
2xCeleron 433MHz

Additional Information:

Here's the backtrace from DDD:

(gdb) where
#0  0x40e21842 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#1  0x40e218b2 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#2  0x40e2408d in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#3  0x40e23c50 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#4  0x40e1f911 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#5  0x40e1e942 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#6  0x40e1e58a in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#7  0x40e1d185 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#8  0x40e26bf7 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#9  0x40e3459c in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#10 0x40fc9194 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#11 0x40fc8b33 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#12 0x40fc6c48 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#13 0x40fb6ccc in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#14 0x40fc6c48 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#15 0x40fca7a5 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#16 0x40e5f8c6 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#17 0x40e5faf5 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#18 0x40e5f907 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#19 0x40fc6c48 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#20 0x40fd4f22 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#21 0x40e5efe1 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#22 0x40e26bf7 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#23 0x40e5d83b in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#24 0x40e357ad in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#25 0x40e4efa5 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#26 0x40e4ecbb in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#27 0x400b650b in PL_HandleEvent () from
/mnt/new-disk/mozilla/nightly/package/./libxpcom.so
#28 0x400b6446 in PL_ProcessPendingEvents () from
/mnt/new-disk/mozilla/nightly/package/./libxpcom.so
#29 0x400b717d in nsEventQueueImpl::ProcessPendingEvents () from
/mnt/new-disk/mozilla/nightly/package/./libxpcom.so
#30 0x405b63bf in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libwidget_gtk.so
#31 0x405b617d in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libwidget_gtk.so
#32 0x40759c10 in g_io_add_watch () from /usr/lib/libglib-1.2.so.0
#33 0x4075b2d9 in g_get_current_time () from /usr/lib/libglib-1.2.so.0
#34 0x4075b4dc in g_get_current_time () from /usr/lib/libglib-1.2.so.0
#35 0x4075ba7c in g_main_run () from /usr/lib/libglib-1.2.so.0
#36 0x406811e7 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#37 0x405bb710 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libwidget_gtk.so
#38 0x40f0ac3a in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#39 0x40e0e4b0 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#40 0x4101b50c in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#41 0x40e9d666 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#42 0x40e4ea31 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#43 0x40e4e979 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#44 0x40e145e1 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#45 0x40e12dba in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#46 0x40e4eb07 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#47 0x40e4e90a in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgklayout.so
#48 0x4114f6fe in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgkview.so
#49 0x4114f6a3 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgkview.so
#50 0x4114f6a3 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgkview.so
#51 0x41157f2e in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgkview.so
#52 0x4114e2ed in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libgkview.so
#53 0x405c2a8a in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libwidget_gtk.so
#54 0x405c29ad in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libwidget_gtk.so
#55 0x405c2b10 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libwidget_gtk.so
#56 0x405c3b7f in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libwidget_gtk.so
#57 0x405c777f in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libwidget_gtk.so
#58 0x405bdcf7 in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libwidget_gtk.so
#59 0x405bdbba in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libwidget_gtk.so
#60 0x4072e077 in gdk_wm_protocols_filter () from /usr/lib/libgdk-1.2.so.0
#61 0x4075b2d9 in g_get_current_time () from /usr/lib/libglib-1.2.so.0
#62 0x4075b8e3 in g_get_current_time () from /usr/lib/libglib-1.2.so.0
#63 0x4075ba7c in g_main_run () from /usr/lib/libglib-1.2.so.0
#64 0x406811e7 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#65 0x405b68ac in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libwidget_gtk.so
#66 0x403802ca in NSGetModule () from
/mnt/new-disk/mozilla/nightly/package/components/libnsappshell.so
#67 0x804d437 in JS_PushArguments ()
#68 0x804d836 in JS_PushArguments ()
#69 0x4024ea42 in __libc_start_main () from /lib/libc.so.6
(gdb)

And here are Talkback IDs:
TB15691747Y
TB15692039Z
TB15693479W
TB15693480M
(Reporter)

Comment 1

18 years ago
Created attachment 12843 [details]
testcase created from original page
(Reporter)

Comment 2

18 years ago
Attached a testcase. Note that if '<p>Text paragraph.</p>' line is removed page
works fine.

Comment 3

18 years ago
Confirmed under linux 2000081108.

Interestingly, clicking on the browse button does not bring up the Mozilla
filepicker, instead it brings up the old gtk one. I wonder if that's anything to
do with it ?

Comment 4

18 years ago
over to xp toolkit/widgets, as per component descript pages.
Assignee: asa → trudelle
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Toolkit/Widgets
Ever confirmed: true
QA Contact: doronr → jrgm

Comment 5

18 years ago
Well, I can't reproduce this in 2000081108 and 2000081308 linux (or on win2k
for 2000081108). Possibly should be resolved as WORKSFORME without more 
information on how to reproduce this.

At any rate, this is HTML Form Controls, not XPToolkit. -> rods
Assignee: trudelle → rods
Component: XP Toolkit/Widgets → HTML Form Controls
QA Contact: jrgm → ckritzer
(Reporter)

Comment 6

18 years ago
I tried with 2000081309 on Linux. Both testcase and sample URL worked, no crash
and even file upload worked
(Assignee)

Comment 7

18 years ago

*** This bug has been marked as a duplicate of 49010 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Target Milestone: --- → M22

Comment 8

18 years ago
Adding crash keyword for fix and/or verification escalation
Keywords: crash

Comment 9

18 years ago
Marking VERIFIED DULICATE on:
- LinuxRH62 2000-09-13-08-M18 Commercial
- Win98     2000-09-13-08-M18 Mozilla
- MacOS86   2000-09-13-04-M18 Commercial
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.