Article links in e-mail notifications should use bl=n

VERIFIED FIXED in 1.2.1

Status

support.mozilla.org
Knowledge Base Software
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: Underpass, Assigned: paulc)

Tracking

unspecified
1.2.1

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: sumo_only)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; it; rv:1.9.0.8) Gecko/2009032608 Firefox/3.0.8
Build Identifier: 

When you receive an email notifications for article changes, under the text

"You can view the page by following this link:"

the proposed link doesn't have the bl=n notation, so very often is not the link to the intended page but it falls back to your locale.

Reproducible: Always
(Assignee)

Updated

9 years ago
Assignee: nobody → paul.craciunoiu
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

9 years ago
Created attachment 384197 [details] [diff] [review]
patch v1

Seems like a simple change, but I don't want to break anything, so we should test this carefully.
Attachment #384197 - Flags: review?(laura)
(Assignee)

Comment 2

9 years ago
Just a quick note: I'm assigning bugs that are patch-ready to the next milestone, so we can land them sooner rather than later, but of course we can push them out.
Target Milestone: --- → 1.3

Comment 3

9 years ago
Comment on attachment 384197 [details] [diff] [review]
patch v1

QA++ on this one too.
Attachment #384197 - Flags: review?(laura) → review+
(Assignee)

Comment 4

9 years ago
r29675 / r29676

Yeah, agree with Laura. Need to test various notifications (not just for articles) to see if links are broken
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: 1.3 → 1.2.1
Verified FIXED; this didn't break my forum-reply notification links, and it *did* put the bl=n parameter suffix correctly on the page changed/created notifications.
Status: RESOLVED → VERIFIED
Whiteboard: sumo_only
You need to log in before you can comment on or make changes to this bug.