Closed Bug 488255 Opened 11 years ago Closed 11 years ago

Bookmark name in editBookmarkPanel is invisible when name picker hasn't focus

Categories

(Firefox :: Theme, defect, P2)

3.5 Branch
All
macOS
defect

Tracking

()

VERIFIED FIXED
Firefox 3.6a1

People

(Reporter: whimboo, Assigned: dao)

References

Details

(Keywords: regression, verified1.9.1)

Attachments

(2 files)

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090413 Shiretoko/3.5b4pre ID:20090413031313

Bookmarking a page and clicking the star again makes the bookmark name invisible when the name folder hasn't focus.

Steps:
1. Bookmark a page by clicking the star
2. Click the star again and focus any textbox but not the name picker

With step 2 the bookmarks name isn't visible anymore.
Flags: blocking-firefox3.5?
Attached image screenshot
os x only? cannot reproduce on win.
Seems so. Cannot reproduce on XP too. More a theme bug?
Blocks: 484022
Regressed between the builds 09040903 and 09041903. Bug 484022 falls into this range.
Component: Places → Theme
QA Contact: places → theme
Attached patch patchSplinter Review
Assignee: nobody → dao
Attachment #372658 - Flags: review?(mstange)
Flags: blocking-firefox3.5? → blocking-firefox3.5+
Priority: -- → P2
Whiteboard: [has patch][needs review mstange]
Attachment #372658 - Flags: review?(mstange) → review+
http://hg.mozilla.org/mozilla-central/rev/901cebb1315d

I'll need to remember not to land the text-align:end change on the 1.9.1 branch, as it's not supported there...
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Whiteboard: [has patch][needs review mstange]
Target Milestone: --- → Firefox 3.6a1
Verified fixed on trunk and 1.9.1 with:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090421 Minefield/3.6a1pre ID:20090421032809

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090421 Shiretoko/3.5b4pre ID:20090421030848
Status: RESOLVED → VERIFIED
No longer blocks: 491027
Depends on: 491027
You need to log in before you can comment on or make changes to this bug.