Flash64 plugin crashes seamonkey 2.0a3 for x86_64 crashes at www.lala.com when Javascript is enabled

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
10 years ago
3 years ago

People

(Reporter: mozilla.org, Assigned: mmelanso)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b3pre) Gecko/20090327 SeaMonkey/2.0a3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b3pre) Gecko/20090327 SeaMonkey/2.0a3

I built an x86_64 Linux version of Seamonkey 2.0a3.  With Javascript enabled, visiting www.lala.com causes Seamonkey to crash.  This does not happen with the pre-compiled 32-bit Linux version.  Therefore, I suspect that there is a bug in the Javascript engine that manifests itself only on 64-bit builds.

Reproducible: Always

Comment 1

10 years ago
Can you get a stacktrace for this crasher? You need to build with --enable-debugger-info-modules for that. Best would be if you can try this with a current comm-central/1.9.1 build (if possible).
Version: unspecified → Trunk
(Reporter)

Comment 2

10 years ago
How do I download the latest code?  I followed the instructions on https://wiki.mozilla.org/SeaMonkey:hg-based_build, but then it tried to download updates via cvs, and my corporate firewall blocked that.  Is there a way I can just download a tarball like I did for 2.0a3?

Comment 3

10 years ago
Don't think we provide such tarballs (we do have tarballs like http://hg.mozilla.org/comm-central/archive/tip.tar.bz2 but those only include the comm-central source and nothing else). You could add this option to your .mozconfig to skip CVS (assuming hg works fine):
ac_add_options --disable-ldap
and use this command to check out:
python client.py checkout --skip-ldap --skip-chatzilla
(maybe the skip-... options need to be before "checkout", just test what works). This will give you a build without LDAP support and Chatzilla.
(Reporter)

Comment 4

10 years ago
Ok, I rebuilt 2.0a3 with --enable-debugger-info-modules, visited lala.com and got this output on the command line:

$ /usr/local/lib/seamonkey-2.0a3/seamonkey
/usr/local/lib/seamonkey-2.0a3/run-mozilla.sh: line 131: 11121 Illegal instruction     "$prog" ${1+"$@"}

Now what?

Comment 5

10 years ago
Start SeaMonkey with "seamonkey -g" (should start SeaMonkey inside gdb), maybe type "run" to run SeaMonkey and as soon as it has crashed, type "bt" to get a stacktrace. Copy that stacktrace into the bug here. Exit with "exit" on the gdb shell.
(Reporter)

Comment 6

10 years ago
It looks like it's missing some debug info:

Program received signal SIGILL, Illegal instruction.
0x00007fffcccd0ed6 in ?? ()
(gdb) bt
#0  0x00007fffcccd0ed6 in ?? ()
#1  0x00007fffffffb7b0 in ?? ()
#2  0x00007fffcfc4e000 in ?? ()
#3  0x00007fffcff279e8 in ?? ()
#4  0x00007fffcfcbacf0 in ?? ()
#5  0x0000000400000001 in ?? ()
#6  0x000000090000000a in ?? ()
#7  0x000001230000000e in ?? ()
#8  0x00007fffd137a19e in NSS_CMSMessage_GetContentInfo ()
   from /usr/lib/mozilla/plugins/libflashplayer.so
#9  0x00007fffd137a2c1 in NSS_CMSMessage_GetContentInfo ()
   from /usr/lib/mozilla/plugins/libflashplayer.so
#10 0x00007fffcfdd8368 in ?? ()
#11 0x00007fffcfd152a8 in ?? ()
#12 0x00007fff00000004 in ?? ()
#13 0x00007fffcfe9a0c0 in ?? ()
#14 0x0000000000000000 in ?? ()

Comment 7

10 years ago
I wonder if Flash has anything to do this. Can you try to move the flash plugin to another folder and see if it still crashes?
(Reporter)

Comment 8

10 years ago
Sure enough, removing the flash plugin makes the problem go away.  This is the 64-bit alpha plugin from Adobe, which causes the same problem on a lot of other sites, so I guess this bug is invalid.

Comment 9

10 years ago
well, it's technically invalid, however we do have people from flash here.

could you please provide the version of this plugin? (about:plugins should list it)
Assignee: nobody → msintov
Component: General → Plug-ins
Keywords: crash
Product: SeaMonkey → Core
QA Contact: general → plugins
Summary: Seamonkey 2.0a3 for x86_64 crashes at www.lala.com when Javascript is enabled → Flash64 plugin crashes seamonkey 2.0a3 for x86_64 crashes at www.lala.com when Javascript is enabled

Updated

10 years ago
Assignee: msintov → mmelanso
(Reporter)

Comment 10

10 years ago
about:plugins says:

    File name: libflashplayer.so
    Shockwave Flash 10.0 r22

Comment 11

10 years ago
I believe I'm having the same problem with
Mozilla/5.0 (X11; N; Linux x86_64; en-US; rv:1.9.1pre) Gecko/20090611 Firefox/3.5
and
File name: libflashplayer.so
Shockwave Flash 10.0 r22,
which is the current x86_64 version.  It worked before I installed Fedora 11 today.

Firefox crashes and does not even give me the usual dialog box about whether I want to report a crash.

Swfdec does not work for me.  I might try to go back to nspluginwrapper, but that caused all sorts of problems.
(Reporter)

Comment 12

9 years ago
Just FYI, I'm still experiencing the problem with Seamonkey 2.0rc2 and flash 10.0.32.18, both 64-bit.  In fact, pretty much all flash crashes the browser now.

Updated

9 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-flash
Version: Trunk → 10.x
(Reporter)

Comment 13

3 years ago
I think we can mark this bug as INVALID (or some other resolution), since lala.com no longer exists.

Comment 14

3 years ago
I'm closing a lot of bugs which are filed as Adobe Flash bugs which are either irrelevant, not actionable, or not serious enough to track in the Mozilla bug tracker. For the most part, Flash bugs should be filed in Adobe bugbase, and we'll only track a few highly-critical issues in the Mozilla tracker.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INCOMPLETE

Comment 15

3 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 10.x → unspecified
You need to log in before you can comment on or make changes to this bug.