Engine sync prefs UI should be generated dynamically

RESOLVED DUPLICATE of bug 493001

Status

RESOLVED DUPLICATE of bug 493001
10 years ago
9 years ago

People

(Reporter: Mardak, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Seems like we hard code which things are disabled, so this causes inconsistencies with seamonkey which just reuses the firefox prefpane.

So we would probably want to uncheck disabled engines too even though the pref might say checked.

Comment 1

10 years ago
The correct solution, imo, is to generate that UI dynamically based on which engines are registered and check/uncheck enabled ones.

Perhaps with the addition that we can add a few hardcoded (disabled) ones, for the same reason they are there now--so that users know what might be in store for the future.
Summary: Disabled/checked state of engine sync list doesn't check registered engines → Engine sync prefs UI should be generated dynamically

Updated

9 years ago
Target Milestone: -- → 1.0

Updated

9 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
Version: Trunk → unspecified
QA Contact: weave → general

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 493001
You need to log in before you can comment on or make changes to this bug.