Status

MailNews Core
Backend
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: dougt, Assigned: dougt)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

18 years ago
When before connecting with the secure socket, we dereference a null comptr.  I
am using yesterday's build.  

###!!! ASSERTION: nsAppFileLocationProvider not thread-safe: 'owningThread ==
NS_CurrentThread()', file nsDebug.cpp, line 436
###!!! Break: at file nsDebug.cpp, line 436
###!!! ASSERTION: nsAppFileLocationProvider not thread-safe: 'owningThread ==
NS_CurrentThread()', file nsDebug.cpp, line 436
###!!! Break: at file nsDebug.cpp, line 436
###!!! ASSERTION: You can't dereference a NULL nsCOMPtr with operator->().:
'mRawPtr != 0', file ../../../dist/include/nsCOMPtr.h, line 649
###!!! Break: at file ../../../dist/include/nsCOMPtr.h, line 649


Stack crawl coming soon....


Maybe it is because I don't have PSM installed..... still we should not crash.
(Assignee)

Comment 1

18 years ago
#0  0x403abe23 in ?? () from /lib/libc.so.6
#1  0x401343c4 in DoMethodDescriptor (arena=0x8087300, cursor=0xbfffb158,
md=0x8cbec50, id=0x8cbeaf0) at xpt_struct.c:716
#2  0x40133ec1 in DoInterfaceDescriptor (arena=0x8087300, outer=0xbfffb20c,
idp=0x8cbdffc) at xpt_struct.c:593
#3  0x401333e0 in DoInterfaceDirectoryEntry (arena=0x8087300, cursor=0xbfffb20c,
ide=0x8cbdfe4, entry_index=18)
    at xpt_struct.c:293
#4  0x401331a4 in XPT_DoHeader (arena=0x8087300, cursor=0xbfffb20c,
headerp=0xbfffb228) at xpt_struct.c:249
#5  0x4012b5dc in xptiInterfaceInfoManager::ReadXPTFile (this=0x8086e80,
aFile=0x8ca4760, aWorkingSet=0x8086e90)
    at xptiInterfaceInfoManager.cpp:284
#6  0x4012b80d in xptiInterfaceInfoManager::LoadFile (this=0x8086e80,
aTypelibRecord=@0xbfffb2c4, aWorkingSet=0x8086e90)
    at xptiInterfaceInfoManager.cpp:331
#7  0x4012895b in xptiInterfaceInfo::ResolveLocked (this=0x80ece40,
aWorkingSet=0x8086e90) at xptiInterfaceInfo.cpp:135
#8  0x401288a7 in xptiInterfaceInfo::Resolve (this=0x80ece40, aWorkingSet=0x0)
at xptiInterfaceInfo.cpp:103
#9  0x4012a146 in xptiInterfaceInfo::EnsureResolved (this=0x80ece40,
aWorkingSet=0x0) at xptiprivate.h:515
#10 0x40128dce in xptiInterfaceInfo::GetParent (this=0x80ece40,
parent=0xbfffb39c) at xptiInterfaceInfo.cpp:249
#11 0x4011fd79 in nsProxyEventClass::GetNewOrUsedClass (aIID=@0x424ea140) at
nsProxyEventClass.cpp:111
#12 0x401207df in nsProxyEventObject::GetNewOrUsedProxy (destQueue=0x80edc30,
proxyType=5, aObj=0x8be40f0, aIID=@0x424ea140)
    at nsProxyEventObject.cpp:161
#13 0x40122671 in nsProxyObjectManager::GetProxyForObject (this=0x82026f8,
destQueue=0x80edc30, aIID=@0x424ea140, 
    aObj=0x8be40f0, proxyType=5, aProxyObject=0x8ca34d4) at
nsProxyObjectManager.cpp:188
#14 0x4247d9cd in nsImapProtocol::SetupSinkProxy (this=0x8ca3428) at
nsImapProtocol.cpp:462
#15 0x42480bce in nsImapProtocol::LoadUrl (this=0x8ca3428, aURL=0x8ca3064,
aConsumer=0x0) at nsImapProtocol.cpp:1335
#16 0x42460fb9 in nsImapIncomingServer::GetImapConnectionAndLoadUrl
(this=0x8bb7090, aClientEventQueue=0x80edc30, 
    aImapUrl=0x8ca3060, aConsumer=0x0) at nsImapIncomingServer.cpp:345
#17 0x424a88d4 in nsImapService::GetImapConnectionAndLoadUrl (this=0x8c171c8,
aClientEventQueue=0x80edc30, aImapUrl=0x8ca3060, 
    aConsumer=0x0, aURL=0x0) at nsImapService.cpp:1905
#18 0x4249f73a in nsImapService::SelectFolder (this=0x8c171c8,
aClientEventQueue=0x80edc30, aImapMailFolder=0x8be404c, 
    aUrlListener=0x8be40c0, aMsgWindow=0x8ba18b0, aURL=0x0) at
nsImapService.cpp:199
#19 0x4246b7be in nsImapMailFolder::UpdateFolder (this=0x8be4030,
msgWindow=0x8ba18b0) at nsImapMailFolder.cpp:503
#20 0x40136c95 in XPTC_InvokeByIndex (that=0x8be404c, methodIndex=40,
paramCount=1, params=0xbfffba48)
    at xptcinvoke_unixish_x86.cpp:134



more poking soon.
Keywords: crash, nsbeta3

Comment 2

18 years ago
*** Bug 48965 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

18 years ago
Not totally sure if I fix your dup, but I found the cause of the crash that I
was seeing.  Some of the directory service defines have been renamed, and the
change was not reflected into nsPSMComponent.  We were getting a null back as a
directory location and kindly dereferencing it.  

(Assignee)

Comment 4

18 years ago
fix checked in.
(Assignee)

Comment 5

18 years ago
x
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 6

18 years ago
QA->me
QA Contact: lchiang → huang

Comment 7

18 years ago
Verified on Linux 08-25-12-M18 commercial build.
No crash anymore for connecting to IMAP SSL. Marking as verified!!
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.