Closed Bug 488499 Opened 12 years ago Closed 12 years ago

Registry key SeaMonkeyHTML created under HKCU rather than HKCR

Categories

(SeaMonkey :: Installer, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.0b1

People

(Reporter: ZaneUJi, Assigned: mcsmurf)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090414 SeaMonkey/2.0b1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090414 SeaMonkey/2.0b1pre

When HKEY_CLASSES_ROOT\SeaMonkeyHTML exists, installer creates HKEY_CURRENT_USER\SeaMonkeyHTML.

Reproducible: Always

Steps to Reproduce:
1.Run REGEDIT.EXE, delete HKEY_CURRENT_USER\SeaMonkeyHTML if it exists.
2.Install SeaMonkey twice.
3.Refresh and check if there is a key named SeaMonkeyHTML under HKEY_CURRENT_USER.
Actual Results:  
HKEY_CURRENT_USER\SeaMonkeyHTML has been created.

Expected Results:  
The old HKEY_CLASSES_ROOT\SeaMonkeyHTML should be overwritten.
That's certainly a bug. As far as I see this, the problem is the code at http://hg.mozilla.org/comm-central/annotate/f525b7b9b3f5/suite/installer/windows/nsis/shared.nsh#l677
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached patch PatchSplinter Review
Easy to review.
Assignee: installer → bugzilla
Status: NEW → ASSIGNED
Attachment #372917 - Flags: review?(bugzilla)
Attachment #372917 - Flags: review?(bugzilla) → review+
Version: unspecified → Trunk
Pushed to comm-central, changeset 731cfa3610c5.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0b1
You need to log in before you can comment on or make changes to this bug.