Support Tag Searching

RESOLVED FIXED in 5.0.7

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED FIXED
9 years ago
2 years ago

People

(Reporter: clouserw, Assigned: Yem Huynh)

Tracking

unspecified
5.0.7
Dependency tree / graph

Details

(Whiteboard: [webmocha])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

9 years ago
Tags are no fun unless people can search for them and see pages filled with different sized words.  It also makes for a fun game which I will hereby dub "Tag Tales" the goal of which will be to tell a short story using the sizes of words to determine order.  I suspect it will devolve from a fine abuse of tagging into "lol look how big the word balls is lets add it to more stuff."  Nevertheless, this bug also builds on the spec ( http://docs.google.com/Doc?docid=dds6vwb4_1dxwx5vg3&hl=en ) and includes:

1.7: Search engine support
1.9: Tags are shown on add-on listing pages
1.10: search result page when searching only for a tag,  Including URL support
(Reporter)

Updated

9 years ago
Blocks: 488520

Comment 1

9 years ago
I'm futzing around with tags on an individual add-on page and could use some feedback.

http://people.mozilla.com/~nlee/amo/tags/wireframes/v1/

Click on the image to cycle through the states.

The goal here in my mind is to keep the tags as clustered as possible to avoid having them take over the page if there are lots of them. I'm not sure if what I'm suggesting as far as removing tags is doable from a technical perspective; please comment on this as well.
(Reporter)

Comment 2

9 years ago
I think it looks fine.  I'm not sure why a user has to click on a tag for the close button to appear.  I think it would be better to not grow the button and just have the close button appear on mouse over (and mouse-over of the close button shows a useful tooltip).
(Reporter)

Updated

9 years ago
Depends on: 410205
(Reporter)

Updated

9 years ago
Blocks: 410205
No longer depends on: 410205
(Reporter)

Updated

9 years ago
Assignee: nobody → mikelee

Updated

9 years ago
Assignee: mikelee → yem.huynh

Comment 3

9 years ago
Tasks here include:
+ Integrate tags into query-based Search (MySQL, CakePHP)
+ Add new unit tests for new test cases. Update any existing tests (SimpleTest)

Updated

9 years ago
Whiteboard: [webmocha]

Updated

9 years ago
Blocks: 496658

Updated

9 years ago
Blocks: 496659
(Assignee)

Comment 4

9 years ago
-added db support for tag searching
-added support for tag indexing in update-search-views.php
-added controller support for searching on tags
-added controller support for searching and refining results on a tag
-added model support for finding all unique tags for a given search resultset
-added SimpleTests
(Assignee)

Comment 5

9 years ago
-added db support for tag searching
-added support for tag indexing in update-search-views.php
-added controller support for searching on tags
-added controller support for searching and refining results on a tag
-added model support for finding all unique tags for a given search resultset
-added SimpleTests
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
For future reference, it'd be helpful if you listed in which SVN revision # you implemented features.

If you do "rxxxx" without the quotes, where "xxxxx" is the revision number, Bugzilla will auto-link to viewvc.svn.mozilla.org; thanks!
(Assignee)

Comment 7

9 years ago
revisions:
27745
27748
27749
27750

Comment 8

9 years ago
With the r's :)

r27745
r27748
r27749
r27750

Updated

9 years ago
Duplicate of this bug: 496658

Comment 10

9 years ago
Needs a few additional tasks:

1. find out why Mark is not getting any results when he does searches (simpletests are working for Yem, need to find out why API doesn't work for Mark)
2. support tag-only search (aiming to get this done tonight)
3. write some more simpletests. search is tricky so it requires more simpletests
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 11

9 years ago
Created attachment 385685 [details] [diff] [review]
patch

finished with functionality:

-added search by tags only
-added weight to tag search
-added more simpletests

Attached patch contains files with these changes/updates.
(Assignee)

Comment 12

9 years ago
marking as fixed after attaching patch.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

9 years ago
Created attachment 385731 [details] [diff] [review]
new patch for search.

updated controllers that call search()
Attachment #385685 - Attachment is obsolete: true
(Reporter)

Comment 14

9 years ago
r28897.  This patch set the default debug level to 1 and added two print_r() statements.  Please be more careful with your patches.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.