Both msgReadSMIMEOverlay and msgHdrViewOverlay re-import messenger.css so we have to do extra work to override styles in messenger.css.

RESOLVED FIXED in seamonkey2.0b1

Status

SeaMonkey
Themes
--
enhancement
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Philip Chee, Assigned: stefanh)

Tracking

(Blocks: 1 bug)

Trunk
seamonkey2.0b1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

6.31 KB, patch
neil@parkwaycc.co.uk
: review+
neil@parkwaycc.co.uk
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

9 years ago
In Bug 413385 I had to use !important to get a style override to work due to messenger.css re-imported twice.

From Bug 413385 Comment 6 :

> Created an attachment (id=372373)
> DOMi CSS pane on mailnews toolbarbutton.
> 
>>>>+  min-width: 0px !important;
>>>> }
>>> Is this important really necessary?
>> It wasn't in Navigator but for some reason I had to use !important in
>> messenger.
> 
> Looking at it in DOMi first chrome://communicator/skin/button.css specifies:
> .toolbarbutton-1 { min-width: 50px }
> 
> Then I specify in chrome://messenger/skin/primaryToolbar.css:
> .toolbarbutton-1 {min-width: 0px }
> 
> Then after that chrome://communicator/skin/button.css is again loaded (twice!)
> putting the min-width back to 50px (since all these rules have equal weights,
> the last one loaded wins).
> 
> In Navigator buttons.css is only loaded once so I didn't have to use
> !important. I made sure I didn't have any extensions installed in the profile
> so this isn't caused by some extension so I guess two of the standard messenger
> overlays are also pulling in buttons.css but I'm not sure which.

From Bug 413385 Comment 8 :

> Both msgReadSMIMEOverlay and msgHdrViewOverlay re-import messenger.css so file
> a bug and note it here too.
Blocks: 488697
(Assignee)

Comment 1

9 years ago
Created attachment 386887 [details] [diff] [review]
Remove @import rules

I had an issue with this for a couple of years ago (https://bugzilla.mozilla.org/show_bug.cgi?id=249744#c52). It looks like there are 3 files. I can't see any reason for the @import rules, but I haven't got any encryption facilities - that is, I have only tested without encrypting msgs. Philip, do you have the ability to test this?
Assignee: nobody → stefanh
Status: NEW → ASSIGNED
(Assignee)

Updated

9 years ago
Blocks: 249744
(Assignee)

Comment 2

9 years ago
Comment on attachment 386887 [details] [diff] [review]
Remove @import rules

Well, looking at bug 488697 , I guess this is pretty straight-forward even though I haven't tested with encryption.
Attachment #386887 - Flags: superreview?(neil)
Attachment #386887 - Flags: review?(neil)
(Assignee)

Updated

9 years ago
Component: UI Design → Themes
QA Contact: ui-design → themes
Target Milestone: --- → seamonkey2.0b2
(Reporter)

Comment 3

9 years ago
I don't do encrypted messages either, but overlays don't need to import messenger.css anyway. And I should point out that philor read this bug and removed the imports from Thunderbird in Bug 488697 and they haven't noticed any regressions since.

Updated

9 years ago
Attachment #386887 - Flags: superreview?(neil)
Attachment #386887 - Flags: superreview+
Attachment #386887 - Flags: review?(neil)
Attachment #386887 - Flags: review+
(Assignee)

Comment 4

9 years ago
Pushed 8c1eb962573b to comm-central.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: seamonkey2.0b2 → seamonkey2.0b1
You need to log in before you can comment on or make changes to this bug.