Hg Account Request - Chris Jones <cjones@mozilla.com>

RESOLVED FIXED

Status

RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: cjones, Unassigned)

Tracking

Details

(Whiteboard: ssh-key, form, voucher1, voucher2, sr)

Attachments

(1 attachment)

The three biggest projects of mine have been:

(1) Bug 476536: Assertions need to be able to check the state of particular locks (nspr)

(2) Bug 58904: XPCOM should have nsLock strong type to match nsAutoLock
Associated bugs: 483714, 486606, 456272, 487918 (and friends)

(3) Bug 482373: Static analysis to check safety of nsCOMPtr::swap
Associated bugs: 482565, 482374

This is the full list of bugs to which I've contributed patches:

https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=RESOLVED&bug_status=VERIFIED&bug_status=CLOSED&resolution=FIXED&resolution=WORKSFORME&resolution=INCOMPLETE&resolution=MOVED&resolution=---&emailassigned_to1=1&emailtype1=exact&email1=jones.chris.g%40gmail.com&chfieldto=Now
Taras, please vouch for bug 482373.
Benjamin, please vouch for bug 58904.
Wan-Teh, please vouch for bug 476536.
Apparently I need super-review, which Benjamin can provide.

Comment 5

10 years ago
(In reply to comment #1)
> Taras, please vouch for bug 482373.

I vouch for Chris.
Need your SSH public key attached to the bug, your Committer's Agreement filled out and given to Erica, and two vouchers plus one SR to vouch for you (one of which must not work for MoCo).
OS: Mac OS X → All
Hardware: x86 → All
Summary: Commit access for cjones@mozilla.com → Hg Account Request - Chris Jones <cjones@mozilla.com>
Blocking pubkey/paperwork until I can get the vouchers.
(In reply to comment #5)
> (In reply to comment #1)
> > Taras, please vouch for bug 482373.
> 
> I vouch for Chris.

As far as I can tell, you're not the module owner or peer of any existing module, so I'm afraid your vouch isn't usable here.

Comment 9

10 years ago
Taras is the module owner of the static analysis code. It doesn't happen to have a despot module because there is no CVS directory for it.

sr/vouch/whatever=me

Comment 10

10 years ago
I vouch for Chris Jones.  I am not an employee of Mozilla Corporation.
(In reply to comment #9)
> Taras is the module owner of the static analysis code. It doesn't happen to
> have a despot module because there is no CVS directory for it.

Still can add it to Despot without any source dirs...
Whiteboard: voucher1, voucher2, sr
I dropped off the commit access form at Erica's desk.
Whiteboard: voucher1, voucher2, sr → ssh-key, voucher1, voucher2, sr

Comment 14

10 years ago
I have received Chris' Committer's Agreement.
Ok, over to IT for Hg account set up with hg_mozilla and hg_mozsrc bits.
Assignee: marcia → server-ops
Whiteboard: ssh-key, voucher1, voucher2, sr → ssh-key, form, voucher1, voucher2, sr
Hg added for hg_mozilla and hg_mozsrc.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

9 years ago
Component: Account Request: Hg → Repository Account Requests
QA Contact: hg-acct-req → repo-acct-req
You need to log in before you can comment on or make changes to this bug.