Closed Bug 488551 Opened 12 years ago Closed 11 years ago

tab title should display number of unread mail (like in the folder pane)

Categories

(Thunderbird :: Toolbars and Tabs, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 528508

People

(Reporter: klonos, Unassigned)

Details

(Whiteboard: [UXprio])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090414 Minefield/3.6a1pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090404 Lightning/1.0pre Shredder/3.1a1pre ID:20090414043927

Right-clicking a mail/search folder and choosing the 'Open in New Tab' option opens it in a new tab as should, but there is no indication of how many unread mail is currently in that folder. In other words there is no '(#of_mail)' next to the folder name like the one we see in the folder pane.

There should be such an indication for starters. Next we need to have this updated for all open tabs as new mail arrives. There should also be a new mail indication (the '*' shown over the folder icon in the folder pane should also be shown over the folder 'favicon' in the tab).

Also I am not sure if the bold text in the name of folders with unread mail in the folder pane should be mirrored in tabs, because bold text is used for indicating currently selected tab. Perhaps we should implement this as well, since selection focus is also indicated by different (brighter) tab background. I am also thinking bold text but slightly gray instead of black, in order to make it differentiate from current tab.

Don't know what you people think about all these (?)... lets talk about it and see what can be done.


Reproducible: Always

Steps to Reproduce:
1. Right-click a mail folder in the folder pane and choose to open in new tab from the context menu that pops up.
2. Tab does open as expected, but there is no indication of new/unread mail.

Actual Results:  
All mail folder tabs have the same text and icon.


Expected Results:  
There should be indication of unread mail (number + unread folder 'favicon' + perhaps bold but gray text).


Special folders like 'Send' and 'Drafts' is an exception, since they have their special icons shown in the tab, but still no total number of unread shown.
I see all the above in WinXP, could people verify this + let us know what applies to other platforms?
Same in OS X, I’d kinda expected to see the unread count.
Confirming RFE.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Summary: tabs should display number of unread mail (like in the folder pane) → tab title should display number of unread mail (like in the folder pane)
Whiteboard: [UXprio]
This appears to be a duplicate of bug 528508.
duping forward to the action
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 528508
You need to log in before you can comment on or make changes to this bug.