Border color not working on long pages when specified per side

RESOLVED DUPLICATE of bug 446323

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 446323
9 years ago
9 years ago

People

(Reporter: yakkyjunk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8

I have code similar to the following:

<div style="border-right:10px solid red;">
 
 .
 .
 .

 Some text repeated many many times over.<br />

 .
 .
 .
</div>

The rendering of the border does not occur throughout the entire page. Depending on the length of the page, it may appear to render at the beginning, stop as you scroll down, start again, stop again, etc.

This is only for very long pages. The example I provided in the URL is 1000 lines with each line actually taking up two lines of rendering due to word wrap.

The problem occurs with border-left, border-top, border-right, and border-bottom. Everything renders fine if using border to put a border around all sides.

The width of the border appears to render, just the coloring fails.





Reproducible: Always

Steps to Reproduce:
1. Make div with style as shown in details
2. Add lots and lots of stuff to render
3. Test
Actual Results:  
Border doesn't display properly

Expected Results:  
Border should display properly

Comment 1

9 years ago
This will be fixed in Firefox 3.5.

This was fixed starting with the 20080723 nightly build.
So it looks like it's thanks to Bug 446323.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 446323

Updated

9 years ago
Component: General → GFX: Thebes
Product: Firefox → Core
QA Contact: general → thebes

Updated

9 years ago
Duplicate of this bug: 490636
You need to log in before you can comment on or make changes to this bug.