Do not let user save empty GUID

RESOLVED FIXED in Future

Status

addons.mozilla.org Graveyard
API
P3
normal
RESOLVED FIXED
9 years ago
2 years ago

People

(Reporter: Aleksey Lim, Unassigned)

Tracking

unspecified
Future

Details

(Whiteboard: [patch])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b3) Gecko/20090412 Gentoo Shiretoko/3.1b3
Build Identifier: 

extracted from #485802 patch set

Reproducible: Always

Actual Results:  
if guid wasn't set while creating add-on user can complete/nominate add-on w/o guid.


Expected Results:  
do not let user complete/nominate add-on w/o guid
(Reporter)

Comment 1

9 years ago
Created attachment 373044 [details] [diff] [review]
Do not let user save empty GUID
Attachment #373044 - Flags: review?
(Reporter)

Updated

9 years ago
Blocks: 485802
(Reporter)

Updated

9 years ago
No longer blocks: 485802

Updated

9 years ago
Assignee: nobody → jbalogh
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → 5.0.5
Priority: -- → P3
1. I would add tests for the empty guid case
2. The `switch ($efield)` should just be `if ($efield == 'guid')` since the error you're printing is `invalid_guid`.
Assignee: jbalogh → nobody

Updated

9 years ago
Target Milestone: 5.0.5 → 5.0.7
Aleksey, any updates on this bug?  Do you have time for this?
Target Milestone: 5.0.7 → 5.0.8
Whiteboard: [patch]

Updated

8 years ago
Target Milestone: 5.0.8 → Future
GUIDs are checked for validity during the upload process.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Attachment #373044 - Flags: review?
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.