Text overwrites dragging in History

VERIFIED DUPLICATE of bug 49094

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 49094
18 years ago
10 years ago

People

(Reporter: jesup, Assigned: David Hyatt)

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
I selected (via menus) Tasks/Tools/History.  When I click on the slider button
and drag, I get serious draw problems, including large undrawn areas and areas
that are overwritten.  See the GIF I'm attaching.  Side note, to be entered as a
separate bug: after I click on the slider button, it doesn't notice the
up-click, and instead follows the mouse until I click again.  Also a separate
but perhaps related bug: very bad performance when dragging.
(Reporter)

Comment 1

18 years ago
Created attachment 12854 [details]
Image of history window with overwrites

Comment 2

18 years ago
Various misbehaviour is later described in bug 49094 "scrollbar thumb is
dragable". But noteworthy: Scrolling with mousewheel does NOT show the
mispainting. I do, h owever, see the same as you on linux 2000081509 when
scrolling by dragging thumb/slider. I think this all boils down to the slider
button bug.

49094 is already set to OS and Platform: ALL

Adding comment there about this bug, i think it can be marked dup (even if you
probably were "first poster"..)

Comment 3

18 years ago
Yes. I disabled D&D for the history.xul, and could no longer reproduce this 
behaviour. There are open bugs addressing tree-scrolling perf, which is the 
other part of why this is happening. Marking this bug a dup of 49094. Thanks.

*** This bug has been marked as a duplicate of 49094 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.