MozillaBuild - windows 2000 : guess-msvc.bat fails due to unfound reg command

RESOLVED DUPLICATE of bug 376376

Status

mozilla.org
MozillaBuild
--
minor
RESOLVED DUPLICATE of bug 376376
9 years ago
9 years ago

People

(Reporter: Samuel Monsarrat, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3
Build Identifier: 

guess-msvc.bat uses the "reg" command to query the windows registry.

On a default installation of Windows 2000, the "reg" command line app is not installed. It is part of the "Support Tools" package that is installable from the Win2000 CD.

When one installs the Support Tools they are installed under: 
"C:\Program Files\Support Tools\" 
which is added to the default path.

guess-msvc.bat overides the default path if MOZ_NO_RESET_PATH is not set. This results to the reg command being inaccessible as "C:\Program Files\Support Tools\" is then removed from the PATH.

guess-msvc.bat should not take the presence of the reg command for granted, and at least inform one that it is not present on the path. Mabe even point one to some further documentation of MozillaBuild explaining that under Windows 2000:
1) you must install the Support Tools
2) you must set MOZ_NO_RESET_PATH

Reproducible: Always

Steps to Reproduce:
1. Install win2000 with all updates
2. Install MozillaBuild
3. Atempt to start any "start-msvc*.bat

Actual Results:  
Command line flashes up, then disapears instantly.

Expected Results:  
Command line comes up and informs one that the reg command is unavailable on this system.
I have no intention to modify MozillaBuild to support Windows 2000.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 376376
You need to log in before you can comment on or make changes to this bug.