Firefox does not start when clicking icon, instead Internet explorer shows "Internet Explorer cannot display the webpage"

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
10 years ago
3 years ago

People

(Reporter: leif.peder, Unassigned)

Tracking

1.9.0 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7
Build Identifier: http://download.mozilla.org/?product=firefox-3.0.8&os=win&lang=en-US

After installing firefox I click the firefox icon in my start menu;
Firefox doesn't start, instead Internet Explorer starts showing the page "Internet Explorer cannot display the webpage"..

The reason I suspect this is caused by firefox and not Windows Vista is that this does not happen with any other program on my machine.

Reproducible: Always

Steps to Reproduce:
1.Launch firefox.exe
Actual Results:  
Firefox doesn't start, instead Internet Explorer starts showing the page "Internet Explorer cannot display the webpage"..

Using Sysinternals Process explorer I can clearly see that firefox.exe is never started, just iexplore.exe. The full command line is:
"C:\Program Files\Internet Explorer\iexplore.exe" -k http://"c:/Program%20Files/Mozilla%20Firefox/firefox.exe"

As you can see iexplore.exe is started with "-k" which starts internet explorer in kiosk-mode (aka. full screen without address-bar).

The same thing happens when i go to "C:\Program Files\Mozilla Firefox" and double-click the firefox.exe file. I've also attempted to use "Run as Administrator".

Expected Results:  
Firefox starts.

I've also confirmed that the problem also occurs with Portable Firefox from PortableApps.com. But here I also get an error message:
Cannot find
file:///C:/Program%20Files/...:/Program%20Files/FirefoxPortable/Data/profile'.
Make sure the path or Internet address is correct.
Does this also happen if you start firefox by double clicking firefox.exe in the application folder?
Component: General → Startup and Profile System
Product: Firefox → Toolkit
QA Contact: general → startup
Version: unspecified → 1.9.0 Branch
(Reporter)

Comment 2

10 years ago
As I've already stated:

The same thing happens when i go to "C:\Program Files\Mozilla Firefox" and
double-click the firefox.exe file. I've also attempted to use "Run as
Administrator".

best regards
(Reporter)

Comment 3

10 years ago
(In reply to comment #1)
> Does this also happen if you start firefox by double clicking firefox.exe in
> the application folder?

Sorry, I'm not used to this comment system..
Please see comment #2: https://bugzilla.mozilla.org/show_bug.cgi?id=488657#c2
(Reporter)

Comment 4

10 years ago
I have additional information:
Just for fun I renamed the firefox.exe file to firebox.exe and that did the trick(!

My conclusion is that this is not a bug in firefox but actually some kind of security policy implemented in my install of Vista that prevent me from properly running a file named firefox.exe..
Some of the settings in Windows are path specific (e.g. compatibility for one). Could you try installing into a new directory such as c:\program files\mozilla firefox2\ by running the installer, selecting custom on the second page,  specifying this new directory on the next page, click next for the remaining pages, and try running Firefox again?
(Reporter)

Comment 6

10 years ago
(In reply to comment #5)
> Some of the settings in Windows are path specific (e.g. compatibility for one).
> Could you try installing into a new directory such as c:\program files\mozilla
> firefox2\ by running the installer, selecting custom on the second page, 
> specifying this new directory on the next page, click next for the remaining
> pages, and try running Firefox again?

Hi Robert,

No need for this as I've already confirmed the problem using firefox portable edition in a custom directory..

It didn't take me long to track down my problem once I found the above mentioned way to circumvent it. I searched the registry for "firefox.exe" and found a key under
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\firefox.exe]

called "Debugger", it's value was 
"\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -k "

So there's my problem right there, when trying to launch _any_ file called firefox.exe Windows is tricked into beliving that it should be debugged using the above command line. Off course this does nothing but starting Internet Explorer in kiosk mode (as previously mentioned).

More about "" here
http://msdn.microsoft.com/en-us/library/a329t4ed(VS.71).aspx

and here
http://msdn.microsoft.com/en-us/library/a329t4ed.aspx

Thank you guys for this great piece of software, can't live without my firefox :-)
Thanks for tracking down the cause
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 8

3 years ago
I am having the same problem in windows 8.1. it said it it firefox but it opens internet exploer
You need to log in before you can comment on or make changes to this bug.