M17 crash after sitting idle for 8 hours

VERIFIED WONTFIX

Status

()

Core
XPCOM
P2
normal
VERIFIED WONTFIX
18 years ago
14 years ago

People

(Reporter: Bob Kanefsky, Assigned: Simon Fraser)

Tracking

({crash, perf})

Trunk
PowerPC
Mac System 9.x
crash, perf
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [p:2] [mac perf])

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Build id 2000080712 on MacOS 9.

I left a browser window up overnight, and when I came back the Mac was in
Macsbug.  As nearly as I can tell from files written by another application
(SETI@home), the crash occurred after  about 8 hours.  As I recall, the page I
left displayed had no animations but might have been running a JavaScript
setInterval.  I'll attach a stack trace.  It referenced unmapped memory while in
an idle loop.
(Reporter)

Comment 1

18 years ago
Created attachment 12855 [details]
Stack trace

Comment 2

18 years ago
Adding crash keyword.
Keywords: crash

Comment 3

18 years ago
over to XPCOM
Component: Browser-General → XPCOM

Comment 4

18 years ago
reassigning.
Assignee: asa → rayw
QA Contact: doronr → leger

Comment 5

18 years ago
This should be assigned to someone who has a Mac.  It is occurring in 
mac-specific code.

Comment 6

18 years ago
Scott, could you help verify this bug and decide who it belongs to?  Thanks.

Comment 7

18 years ago
Updating QA Contact
QA Contact: leger → chofmann

Comment 8

18 years ago
Simon, could you look at this long enough to determine whether it needs to be 
solved in nsbeta3?  It all seems to be mac-specific code, and I am not set up to 
do that right now.
(Assignee)

Comment 9

18 years ago
The stack tells me nothing. A full MacsBug stdlog would be better.

Comment 10

18 years ago
Assigning to Simon for whatever further analysis and triaging are required.
Assignee: rayw → sfraser

Comment 11

18 years ago
adding perf keyword, setting to m19, setting to p2
Keywords: perf
Priority: P3 → P2
Whiteboard: [p:2] [mac perf]
Target Milestone: --- → M19
(Assignee)

Comment 12

18 years ago
No way I can even begin to investigate this without more information from the 
filer, e.g. what page wehre they sitting on, and is it reproducible.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 13

18 years ago
It's not reproducible.  The page it was sitting on was a page I was developing 

which has since changed.

(Reporter)

Comment 14

18 years ago
If it happens again, next time I'll know a stack trace isn't enough and you need 
a StdLog.  Marking as Verified since there's not enough to go on.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 15

18 years ago
Perhaps more useful is the page that was being displayed for those 8 hours (and a 
list of windows open, if it was > 1).

Updated

14 years ago
OS: Mac System 9.x
You need to log in before you can comment on or make changes to this bug.