[FLOAT] Rightfloats isn't positioned correctly when it's wider then window.

RESOLVED INVALID

Status

()

Core
Layout
P3
normal
RESOLVED INVALID
18 years ago
18 years ago

People

(Reporter: sicking, Assigned: buster)

Tracking

({verifyme})

Trunk
verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

An image floated to the right (float: right) isn't positioned correctly if it's 
wider then the window. Steps to reproduce:

1. Load the supplied URL
2. Grab the border left and the right frames (the vertical border)
3. Move the border to the right until the gnu-image is wider then the frame.

Parts of the gnu now goes "off-frame" to the left but should go "off-frame" to 
right. I.e. the left edge of the image should be visible in the frame and the 
right edge should be outside the visible area to right.

Also no vertical scrollbar is shown

Tested width build 2000-08-09-08 on Win98SE

Comment 1

18 years ago
Triaging Clayton's list:

Yet another problem with floats, destined for some of buster's loving attention.

Steve, please check it out when you can.
Assignee: clayton → buster
Summary: Rightfloats isn't positioned correctly when it's wider then window. → [FLOAT] Rightfloats isn't positioned correctly when it's wider then window.
Which spec is it that makes you think that the behaviour you describe is the
correct behaviour?

As I understand the CSS2 spec, what we are doing is correct.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Keywords: verifyme
QA Contact: petersen → py8ieh=bugzilla
Resolution: --- → INVALID
The problem is really that we should be able to show a scrollbar to the left/top
of the origin.
Over to dbaron for verification.
QA Contact: ian → dbaron
Um, do we have a bug on not being able to scroll past the top or left?  I can't
find one.  I almost filed one at least twice, but I don't think I ever did...
You need to log in before you can comment on or make changes to this bug.