always leak some nsFontGTK

VERIFIED DUPLICATE of bug 5547

Status

()

P3
normal
VERIFIED DUPLICATE of bug 5547
18 years ago
14 years ago

People

(Reporter: dbaron, Assigned: erik)

Tracking

({memory-leak})

Trunk
Future
x86
Linux
memory-leak
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tind-mlk])

We always leak a bunch of nsFontGTK, doing just about anything.  They are
allocated in nsFontMetricsGTK::PickASizeAndLoad (line 2013).

I'll add this class to the leak/bloat stats soon - it's not listed.
Keywords: mlk
Whiteboard: [tind-mlk]
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future
There are no cases I see where PickASizeAndLoad returns early (although it could
leak if it does!).
I think *every* font allocated at line 2120 of nsFontMetricsGTK.cpp is leaked.
In other words, no object is responsible for cleaning these fonts up.

erik:  What should be responsible?

*** This bug has been marked as a duplicate of 5547 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

18 years ago
Verifying.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.