The spell checker in Google's email does high light incorrect spelling, however it does not put the selected correct word back into the document

RESOLVED WORKSFORME

Status

Camino Graveyard
General
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: michael.mcenerney, Unassigned)

Tracking

1.8 Branch
x86
Mac OS X

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.21) Gecko/20090327 Camino/1.6.7 (like Firefox/2.0.0.21pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.21) Gecko/20090327 Camino/1.6.7 (like Firefox/2.0.0.21pre)

The spell checker in Google's email does high light incorrect spelling, however it does not put the selected correct word back into the document

Reproducible: Always

Actual Results:  
Does not put the selected word back into the Google email document

Expected Results:  
Replaces the selected word back into the email, like other browsers.

Comment 1

9 years ago
This sounds like bug 405715, but once again I can't reproduce it (in either 1.6.7 or a nightly).
- Is this specific to any particular mode (composing a new email, replying to an existing thread, etc.)?
- What *exactly* are you doing to try to correct words?
- Does this happen with run using Troubleshoot Camino (<http://pimpmycamino.com/parts/troubleshoot-camino>) ?
Version: unspecified → 1.8 Branch
(Reporter)

Comment 2

9 years ago
Composing a new email and then checking the spelling prior to sending.  Gmail highlights in yellow incorrect spelling of the words and then presents possible choices, upon selecting the correct word it doesn't replace the original incorrect spelled word.  It's that simple. Mike.

Comment 3

9 years ago
Please give specific steps for what you are doing (what you are clicking on, and where) when you say "then checking the spelling prior to sending", because I'm still not sure what UI this is or how you are triggering it. The only gmail-specific spellcheck-check I'm aware of is the "Check Spelling" link on the right above the compose box, and when I click it any misspelled words turn bold red and are underlined, which doesn't match your description.

Again, does this happen when running under Troubleshoot Camino?

Comment 4

9 years ago
Nevermind, I see. The UI is different depending on whether or not you are in Rich Text or Plain Text mode, and I was looking at Plain Text.

In rich text mode I can reproduce this in 1.6.7, but not trunk, so WFM (probably due to midas focus fixes, but I'm not sure enough to dup it.)

This will work correctly in Camino 2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Duplicate of this bug: 405715
You need to log in before you can comment on or make changes to this bug.