bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Window truncated when using Windows Classic Theme in XP when Navigation toolbar can no longer shrink

RESOLVED DUPLICATE of bug 428939

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 428939
9 years ago
9 years ago

People

(Reporter: Randi, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 (.NET CLR 3.5.30729)

When resizing the browser window smaller, the Navigation toolbar shrinks. When it can no longer get any smaller and the user continues to resize the browser, the entire window is truncated. This includes the main content window. This means that the right scrollbar will be truncated and the user cannot scroll.

Reproducible: Always

Steps to Reproduce:
1. Use Windows XP (not tested in other operating systems)
2. Set the theme to Windows Classic
3. Slowly resize the browser smaller horizontally
Actual Results:  
The browser window is truncated, including the right scrollbar.

Here is an image of the the scrollbar beginning to truncate:
http://img362.imageshack.us/img362/4596/partiallytruncatedscrol.png

Here is an image of the completely truncated scrollbar:
http://img362.imageshack.us/img362/4503/fullytruncatedscrollbar.png

No navigation toolbar means a normally functioning scrollbar:
http://img362.imageshack.us/img362/5920/nonavigationtoolbar.png

Expected Results:  
When running on XP using the normal XP theme, the browser either refuses to resize any smaller or continues shrinking but truncates the Navigation toolbar, continuing to shrink the main content window appropriately.

When the Navigation toolbar is turned off, there is nothing preventing the browser window from shrinking properly and the main content window is not truncated.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.0 Branch

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 428939
You need to log in before you can comment on or make changes to this bug.