TM: Assertion failure: *bytes == '\0' && JSSTRING_LENGTH(str) == 0

VERIFIED DUPLICATE of bug 488808

Status

()

VERIFIED DUPLICATE of bug 488808
10 years ago
10 years ago

People

(Reporter: cbook, Unassigned)

Tracking

({assertion})

1.9.1 Branch
x86
Mac OS X
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090417 Firefox/3.6a1pre

Happened during a search on flightaware.com and also during a topsite test on bbc.co.uk randomly - i will try to get a testcase.

Assertion failure: *bytes == '\0' && JSSTRING_LENGTH(str) == 0, at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jsstr.cpp:3503


Program received signal SIGTRAP, Trace/breakpoint trap.
JS_Assert (s=0x40c3c4 "*bytes == '\\0' && JSSTRING_LENGTH(str) == 0", file=0x40be54 "/work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jsstr.cpp", ln=3503) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jsutil.cpp:69
69	    abort();
(gdb) bt
#0  JS_Assert (s=0x40c3c4 "*bytes == '\\0' && JSSTRING_LENGTH(str) == 0", file=0x40be54 "/work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jsstr.cpp", ln=3503) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jsutil.cpp:69
#1  0x0036c89d in js_GetStringBytes (cx=0xdf4600, str=0x164bd018) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jsstr.cpp:3502
#2  0x0036cba0 in js_ValueToPrintable (cx=0xdf4600, v=374075636, v2sfun=0x366116 <js_ValueToString>) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jsstr.cpp:2953
#3  0x00288921 in js_AtomToPrintableString (cx=0xdf4600, atom=0x164bf0f4) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jsatom.cpp:87
#4  0x0038f0de in TraceRecorder::import (this=0x116db370, base=0x16549d6c, offset=-24, p=0xd2d340, t=0 '\0', prefix=0x40dc30 "argv", index=0, fp=0xd2d34c) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jstracer.cpp:1800
#5  0x003a023c in TraceRecorder::import (this=0x116db370, treeInfo=0x116c3a90, sp=0x16549d6c, stackSlots=5, ngslots=0, callDepth=0, typeMap=0x116c3af0 "") at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jstracer.cpp:1880
#6  0x003abd46 in TraceRecorder::TraceRecorder (this=0x116db370, cx=0xdf4600, _anchor=0x0, _fragment=0x10bee2f0, ti=0x116c3a90, stackSlots=5, ngslots=0, typeMap=0x116c3af0 "", innermostNestedGuard=0x0, outer=0x0) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jstracer.cpp:1277
#7  0x003abef6 in TraceRecorder::TraceRecorder (this=0x116db370, cx=0xdf4600, _anchor=0x0, _fragment=0x10bee2f0, ti=0x116c3a90, stackSlots=5, ngslots=0, typeMap=0x116c3af0 "", innermostNestedGuard=0x0, outer=0x0) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jstracer.cpp:1296
#8  0x003abfd9 in js_StartRecorder (cx=0xdf4600, anchor=0x0, f=0x10bee2f0, ti=0x116c3a90, stackSlots=5, ngslots=0, typeMap=0x116c3af0 "", expectedInnerExit=0x0, outer=0x0) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jstracer.cpp:3247
#9  0x003ac79f in js_RecordTree (cx=0xdf4600, tm=0x6f8040, f=0x10bee2f0, outer=0x0, globalObj=0x14d20460, globalShape=19315, globalSlots=0x750f20) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jstracer.cpp:3534
#10 0x003afb78 in js_MonitorLoopEdge (cx=0xdf4600, inlineCallCount=@0xbfffacb8) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jstracer.cpp:4428
#11 0x002ca5a7 in js_Interpret (cx=0xdf4600) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jsinterp.cpp:3309
#12 0x002f42cc in js_Invoke (cx=0xdf4600, argc=2, vp=0xd2d008, flags=0) at jsinterp.cpp:1388
#13 0x002bb50a in js_fun_call (cx=0xdf4600, argc=2, vp=0xd2cfc4) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jsfun.cpp:1687
#14 0x002dfc15 in js_Interpret (cx=0xdf4600) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jsinterp.cpp:5148
#15 0x002f42cc in js_Invoke (cx=0xdf4600, argc=1, vp=0xd2cde4, flags=0) at jsinterp.cpp:1388
#16 0x002bb50a in js_fun_call (cx=0xdf4600, argc=1, vp=0xd2cdac) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jsfun.cpp:1687
#17 0x002dfc15 in js_Interpret (cx=0xdf4600) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jsinterp.cpp:5148
#18 0x002f42cc in js_Invoke (cx=0xdf4600, argc=2, vp=0xd2cd9c, flags=0) at jsinterp.cpp:1388
#19 0x002bb50a in js_fun_call (cx=0xdf4600, argc=2, vp=0xd2cd58) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jsfun.cpp:1687
#20 0x002dfc15 in js_Interpret (cx=0xdf4600) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/jsinterp.cpp:5148
#21 0x002f42cc in js_Invoke (cx=0xdf4600, argc=1, vp=0xd2cc20, flags=0) at jsinterp.cpp:1388
#22 0x0922270c in nsXPCWrappedJSClass::CallMethod (this=0xaae70c0, wrapper=0x15d05080, methodIndex=3, info=0x9ab6c8, nativeParams=0xbfffcdd4) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp:1608
#23 0x09219e7d in nsXPCWrappedJS::CallMethod (this=0x15d05080, methodIndex=3, info=0x9ab6c8, params=0xbfffcdd4) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp:561
#24 0x00566628 in PrepareAndDispatch (self=0x14c95de0, methodIndex=3, args=0xbfffcef4) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_unixish_x86.cpp:93
#25 0x00566687 in nsXPTCStubBase::Stub3 (this=0x14c95de0) at xptcstubsdef.inc:1
#26 0x0b95d887 in nsEventListenerManager::HandleEventSubType (this=0x10b22990, aListenerStruct=0x15d17ad8, aListener=0x14c95de0, aDOMEvent=0x14c30090, aCurrentTarget=0x949a00, aPhaseFlags=6) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/content/events/src/nsEventListenerManager.cpp:1090
#27 0x0b95dc85 in nsEventListenerManager::HandleEvent (this=0x10b22990, aPresContext=0x11821c00, aEvent=0x14c94110, aDOMEvent=0xbfffd1f0, aCurrentTarget=0x949a00, aFlags=6, aEventStatus=0xbfffd1f4) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/content/events/src/nsEventListenerManager.cpp:1187
#28 0x0b99100a in nsEventTargetChainItem::HandleEvent (this=0xfe6c20, aVisitor=@0xbfffd1e8, aFlags=6, aMayHaveNewListenerManagers=1) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/content/events/src/nsEventDispatcher.cpp:227
#29 0x0b99124a in nsEventTargetChainItem::HandleEventTargetChain (this=0xfe6da0, aVisitor=@0xbfffd1e8, aFlags=6, aCallback=0x0, aMayHaveNewListenerManagers=1) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/content/events/src/nsEventDispatcher.cpp:291
#30 0x0b991b1b in nsEventDispatcher::Dispatch (aTarget=0x949a00, aPresContext=0x11821c00, aEvent=0x14c94110, aDOMEvent=0x14c30090, aEventStatus=0xbfffd2d0, aCallback=0x0) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/content/events/src/nsEventDispatcher.cpp:508
#31 0x0b991e80 in nsEventDispatcher::DispatchDOMEvent (aTarget=0x949a00, aEvent=0x0, aDOMEvent=0x14c30090, aPresContext=0x11821c00, aEventStatus=0xbfffd2d0) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/content/events/src/nsEventDispatcher.cpp:570
#32 0x0b8b6dda in nsDocument::DispatchEvent (this=0x949a00, aEvent=0x14c30090, _retval=0xbfffd320) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/content/base/src/nsDocument.cpp:6120
#33 0x0b88144c in nsContentUtils::DispatchTrustedEvent (aDoc=0x949a00, aTarget=0x949a00, aEventName=@0xbfffd3a0, aCanBubble=1, aCancelable=1, aDefaultAction=0x0) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/content/base/src/nsContentUtils.cpp:3147
#34 0x0b8b6e64 in nsDocument::DispatchContentLoadedEvents (this=0x949a00) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/content/base/src/nsDocument.cpp:3838
#35 0x0b8ca872 in nsRunnableMethod<nsDocument, void>::Run (this=0x1660c530) at nsThreadUtils.h:264
#36 0x00549d0c in nsThread::ProcessNextEvent (this=0x715970, mayWait=0, result=0xbfffd4e4) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/xpcom/threads/nsThread.cpp:510
#37 0x004d2b1e in NS_ProcessPendingEvents_P (thread=0x715970, timeout=20) at nsThreadUtils.cpp:180
#38 0x098d48f9 in nsBaseAppShell::NativeEventCallback (this=0x733120) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:121
#39 0x0988b39a in nsAppShell::ProcessGeckoEvents (aInfo=0x733120) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/widget/src/cocoa/nsAppShell.mm:412
#40 0x90ffa5f5 in CFRunLoopRunSpecific ()
#41 0x90ffacd8 in CFRunLoopRunInMode ()
#42 0x9356b2c0 in RunCurrentEventLoopInMode ()
#43 0x9356b0d9 in ReceiveNextEventCommon ()
#44 0x9356af4d in BlockUntilNextEventMatchingListInMode ()
#45 0x95a6cd7d in _DPSNextEvent ()
#46 0x95a6c630 in -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] ()
#47 0x95a6566b in -[NSApplication run] ()
#48 0x098887f4 in nsAppShell::Run (this=0x733120) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/widget/src/cocoa/nsAppShell.mm:723
#49 0x0a57d37a in nsAppStartup::Run (this=0x74f320) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/toolkit/components/startup/src/nsAppStartup.cpp:192
#50 0x0008198c in XRE_main (argc=1, argv=0xbfffea7c, aAppData=0x70edf0) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/toolkit/xre/nsAppRunner.cpp:3340
#51 0x000026e3 in main (argc=1, argv=0xbfffea7c) at /work/mozilla/builds/1.9.1-tracemonkey/mozilla/browser/app/nsBrowserApp.cpp:156
Flags: blocking1.9.1?

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 488808
Flags: blocking1.9.1?

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.