Endless loop when loading new tab

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Ruokola Pasi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; fi; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; fi; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8

This is quite rare, but sometimes when simply loading new tab firefox staets to loops endlessly. It start to hang immediately when loading a link to new tab, but I think the new tab appears to tab strip (not sure about this), after that firefox window stops painting and firefox is completely unresponsive.

This doesn't happen with any specific website and I don't think firefox even starts to load the website before it hangs. But I once got this hang while browsing bugzilla.mozilla.org :)

I don't have any extensions and I only have installed flash plug-in plus I have some plug-in stuff from Windows Media Player (npdsplay.dll)

I also catched stacktrace from Firefox with Process Explorer, but I'm not expert with this stuff so I don't know if these are any help.

Here's a stack from the thread that was looping:
ntoskrnl.exe!KiDispatchInterrupt+0x7b
ntoskrnl.exe!KiInterruptDispatch+0x31
xul.dll!XRE_GetFileFromPath+0x1ec
xul.dll!gfxWindowsPlatform::FindFontForCharProc+0x22
xul.dll!gfxPlatform::IsCMSEnabled+0x8404
xul.dll!NS_CycleCollectorSuspect_P+0x542d
xul.dll!gfxFont::Release+0x46f28
USP10.dll!ScriptBreak+0x38
xul.dll!gfxTextRunCache::ReleaseTextRun+0x2a8e
USP10.dll!ScriptApplyDigitSubstitution+0xa97
xul.dll!gfxWindowsPlatform::UpdateFontList+0x2e40
xul.dll!gfxTextRun::AddGlyphRun+0x29e

Another stack from the same thread (only second and third line differ):
ntoskrnl.exe!KiDispatchInterrupt+0x7b
ntoskrnl.exe!KeUpdateSystemTime+0x13a
xul.dll!gfxFont::Release+0x2b274
xul.dll!gfxWindowsPlatform::FindFontForCharProc+0x22
xul.dll!gfxPlatform::IsCMSEnabled+0x8404
xul.dll!NS_CycleCollectorSuspect_P+0x542d
xul.dll!gfxFont::Release+0x46f28
USP10.dll!ScriptBreak+0x38
xul.dll!gfxTextRunCache::ReleaseTextRun+0x2a8e
USP10.dll!ScriptApplyDigitSubstitution+0xa97
xul.dll!gfxWindowsPlatform::UpdateFontList+0x2e40
xul.dll!gfxTextRun::AddGlyphRun+0x29e

If these doesn't help, please tell me what I should do the next time it starts to hang.

Reproducible: Sometimes

Steps to Reproduce:
1. Load a link in some website to new tab (I use midle click or ctrl + click).



Some prefs I have set that might take effect:
browser.tabs.loadBookmarksInBackground = true
browser.tabs.loadDivertedInBackground = true
toolkit.scrollbox.smoothScroll = false (this one changes the tabstrip behaviour)
places.frecency.updateIdleTime = 0 (Not sure about this one, but it's quite unusual)

Comment 1

9 years ago
My bug appears to be a duplicate of this bug, bug 489000, but I'm not absolutely sure. I am running 'Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10' on a Windows XP Home x86 Dell Vostro 1000 laptop. My situation seems to be that but frequently and most times I right click 'Open Link in New Tab', the new tab web page load seems to cause Firefox start to
loops endlessly in that tab. Also, when this happens, the 'Stop loading this page' does not work. Copying the URL for the page, opening a new tab with 'Open a new tab' or 'File>>New Tab' and pasting the URL causes the page to load properly in that new tab. The endlessly looping tab does not need to be closed for the new tab with the pasted URL to load completely.

Comment 2

9 years ago
*** REPEATED FOR TYPOS FIX AND CLARIFICATION***
My bug appears to be a duplicate of this bug, bug 489000, but I'm not
absolutely sure. I am running 'Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10' on a Windows XP Home x86 Dell
Vostro 1000 laptop. My situation seems to be that frequently and most times when
I right click 'Open Link in New Tab', the new tab web page load seems to cause
Firefox start to looping endlessly in that tab. Also, when this happens, the 'Stop loading this page' option does not work. Copying the URL for the page in the endlessly looping tab, opening a new tab with 'Open a new tab' or 'File>>New Tab' and pasting the URL and loading the page causes the page to load properly in that new tab. The endlessly looping tab does not need to be closed for the new tab with the pasted URL to load completely.
(Reporter)

Comment 3

8 years ago
I haven't seen this happen in the last year.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.