Auto search and redirect function not working.

RESOLVED WORKSFORME

Status

()

Firefox
General
--
minor
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Stephen, Unassigned)

Tracking

3.5 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/525.19 (KHTML, like Gecko) Chrome/1.0.154.53 Safari/525.19
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3

For example, before if i typed "CNN" into the address bar it would open CNN.com even if I had never been there before. Now, it just displays the url in a line of code instead of redirecting to it. It's a functionality that I miss and that I feel should still be there as it's giving the code.

Reproducible: Always

Steps to Reproduce:
1.Type CNN into address bar.
2.Hit Enter
3.Read
Actual Results:  
As described in summary. The correct URL is displayed in the line of code that appears, but must be extracted manually.

Expected Results:  
Redirected me to the first result for my search as it has done in all previous versions EXCEPT the most recent before this beta, where the same problem existed. Cannot recall the exact build but the very last one before this and I have had every version/beta.

I would really appreciate a response or fix. It could be a local problem as I don't see a similar bug report?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090416 Shiretoko/3.5b4pre

Testing this with the default settings of a new profile typing cnn in the locationbar seems to work as expected; it goes to http://edition.cnn.com/
Version: unspecified → 3.1 Branch
I'm assuming the value you put in the URL field is the resulting URL that you're brought to?

This is a very strange bug. Could you try doing a little bit of debugging for me?

Go to the Error Console (Tools->Error Console), and clear out any existing entries (using the clear button), and make sure you're on the "Messages" tab. Then copy/paste the following line into the "Code" text box:

top.opener.gPrefService.getCharPref("keyword.URL")

and press enter. That should print out some text that you should be able to right click and copy. Then repeat those steps with this line:

top.opener.gPrefService.getComplexValue("keyword.URL", Components.interfaces.nsIPrefLocalizedString)

The results from that should help pin point the issue.
Component: Search → General
QA Contact: search → general
(Reporter)

Comment 3

9 years ago
As requested above, the two results:

data:text/plain,keyword.URL=http://www.google.com/search?ie=UTF-8&oe=UTF-8&gfns=1&sourceid=navclient&rls=com.google:en-US:official&q=

data:text/plain,keyword.URL=http://www.google.com/search?ie=UTF-8&oe=UTF-8&gfns=1&sourceid=navclient&rls=com.google:en-US:official&q=

Identical. Possible it could be a local problem?
(Reporter)

Comment 4

9 years ago
Worth mentioning also - this is exactly the format of the result I get displayed on screen when I attempt to type a keyword into the address bar.
Ah, thanks, I see what's going on. It looks like the value of your keyword.URL pref is user-set to a bogus value. I was confused because the bogus value would have worked if it was a default value, but as a user-set value it is invalid.

If you haven't been editing your prefs manually, the most likely cause in this case is a broken extension or third party program that's trying to override your default keyword provider. What's strange is that not only is it failing to do that properly, it also appears to be attempting to set it to the default value, which seems rather pointless...

In any case, you should be able to fix this using about:config (see http://kb.mozillazine.org/About:config if you're not familiar with it). If you enter "keyword.URL" in the Filter text box, you should get a single result, and if my theory is right it will be bold (meaning it has a user-set value). You can then reset it to its default value by right clicking it and selecting "Reset". Once you've done that, your searches should work as they used to. Hopefully whatever caused this in the first place won't kick in again; you might want to disable or uninstall any unused or recent extensions.
(Reporter)

Comment 6

9 years ago
I won't pretend to know exactly what's happening, but I have a rough idea. I've disabled any extensions that aren't working, AVG and Realplayer haven't been updated in a bit and weren't supported by the new beta either.

There were two entries in the about:config when I filtered as you said, both in bold. They were:

keyword.URL;data:text/plain,keyword.URL=http://www.google.com/search?ie=UTF-8&oe=UTF-8&gfns=1&sourceid=navclient&rls=com.google:en-US:official&q=

oldKeyword;data:text/plain,keyword.URL=http://www.google.com/search?ie=UTF-8&oe=UTF-8&gfns=1&sourceid=navclient&rls=com.google:en-US:official&q=

I've reset both to default and indeed the searches now work as they should. Many thanks. No idea what may have caused it, unfortunately :(

Cheers :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.