Drag object to new nonexistent tab (creates it) or another tab, but also changes current tab.

RESOLVED INVALID

Status

()

Firefox
Tabbed Browser
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: darkdc277, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090417 Minefield/3.6a1pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090417 Minefield/3.6a1pre (.NET CLR 3.5.30729)

Every time I drag something (image, url, etc) to the tab bar to make a new tab, the new tab is created (which is good), but the current tab is also changed (which isn't what should happen).


Same happens with dragging something to an existing tab, but this only happens if you change the tab on another page (without going to the want-to-change tab)


Reproducible: Always

Steps to Reproduce:
1. Drag something (Image, Link, etc) to the tab bar to create a new tab.

---------
(Other way)

1. Drag something (image, link, etc) to an existing tab (WITHOUT going to the actual tab)
Actual Results:  
The new tab is created (which is wanted), but the current tab is changed also.

--------
(Other way)

1. The existing tab is changed, but the current tab your on is changed also (only if you don't go to the existing tab)

Expected Results:  
The current tab should not change. Only the new/existing tab should be created/changed

Comment 1

9 years ago
I can confirm this is still happening in Firefox 3.5b99

Comment 2

9 years ago
Confirmed in Firefox 3.5 RC3.

Comment 3

9 years ago
Confirmed in Firefox 3.5 Final Release. *sigh*

Comment 4

9 years ago
To add to the description, this happens only if you drag and drop the link or other objects from one window to another window, and probably from another app as well but I have not tried that. If you do this in same window, the problem does not happen. 

So to replicate, you'll open 2 Firefox windows (side by side, on different monitors, etc.) and drag a link from one window to empty tab area on another window which will display the blue arrow indicating that new tab will be created in that position. Once it's dropped, a new window will be created but an existing tab (seems to be last used tab) will also load it which it should not.

I've replicated the bug on 3.5 release. The bug does not exist on 3.0.11 release. The problem can be replicated without any addon, but also can be relicated under Tax Mix Plus addon installed.
(Reporter)

Comment 5

9 years ago
Just like to mention - the problem I had has been fixed, but this was in Minefield (FireFox 3.6a1pre). This was not meant for FireFox 3.5, but seeing as it's happening there, I'll keep this open.

:)

Comment 6

9 years ago
(In reply to comment #4)
> To add to the description, this happens only if you drag and drop the link or
> other objects from one window to another window, and probably from another app
> as well but I have not tried that. If you do this in same window, the problem
> does not happen. 
> 
> So to replicate, you'll open 2 Firefox windows (side by side, on different
> monitors, etc.) and drag a link from one window to empty tab area on another
> window which will display the blue arrow indicating that new tab will be
> created in that position.

This is not the way I am experiencing this bug. I have just installed the latest "stable" version of Firefox and with only ONE WINDOW I am experiencing this problem. I did not have any issues with FFv3.0, but once I upgraded I now experience this.

The way I am encountering the problem is this:

I attempt to drag a link/image/etc. to the tab bar to open up a new tab as I have always done. The new tab is appropriately created as has always been the case, however the original tab also loads the same URL.

This is, in my experience, all taking place within a single window. If it makes a difference, I do in fact have my preferences set to only use a single window, but it *is* affecting me using only a single window.

Comment 7

9 years ago
This bug appears to be caused by the Gmail Manager add-on.
https://addons.mozilla.org/en-US/firefox/addon/1320

I am experiencing the bug as the original poster describes, not as Comment #4 From Sean Apple describes it.

I have emailed the creator of the Gmail Manager add-on.

Comment 8

9 years ago
Thanks for getting in touch with me about this issue. The latest release of Gmail Manager 0.5.7.3 addresses this. Please let me know if you have any issues. Thank you.

- TL

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 9

9 years ago
Just like to mention, when I found this bug, I did not have the Gmail Manager Add-on.

I believe it was because I was using a nightly build, one that can receive errors at anytime.

But glad to see it fixed for everybody else. :)

(Just like to mention, that my issue was already fixed. (Comment #5))

Comment 10

9 years ago
(In reply to comment #8)
> Thanks for getting in touch with me about this issue. The latest release of
> Gmail Manager 0.5.7.3 addresses this. Please let me know if you have any
> issues. Thank you.
> 
> - TL

Thank you so much! The new version of the Gmail Manager seems to have resolved the issue.
You need to log in before you can comment on or make changes to this bug.